RW 8.5.1 doesn't start

Good day,

I have made fresh install of RW 8.5.1. RW doesn’t start as it just hangs, so i have to FORCE QUIT application.

There is no plugins, addons installed - just RW.

I am using macOS High sierra version 10.13.6.

Please help.

Thanks!

KHM

Don’t know what the problem is but can confirm that 8.5.1 runs perfectly well on 10.13.16 in normal circumstances - I use this combination daily.

I have version 10.13.6, not 10.13.16?

Apologies - typo on my part. I meant 10.13.6. Hi Sierra is getting quite dated now but should not cause any issue with RW 8.5.1.

Have you tried the usual Mac fixes such as resetting the PRAM, checking hard drive etc? If so maybe try to re-install RW?

Should PRAM be reseted? Regarding reinstall, i have tried everything - also downgrading with no luck. It is strange as RW doesn’t give no error that i could report? Is this normal?

This doesn’t work, RW still hangs for no reason and with no error?

I’d suggest re-downloading RapidWeaver just incase it became corrupt. Also make sure RapidWeaver is in your Applications folder.

Please let us know how you get on.

1 Like

I have tried all, still no luck. It just wont start and it hangs? And yes RW is in application folder.

Do you use LittleSnitch or similar apps that block outgoing internet traffic?

No, i dont have any of those apps. This is happening on fresh install of MacOs and Rapidweaver 8.5.1. This is really frustrating as it just hangs on every run, it does not give any feedback whatsoever.

Are you a new RW user or did you have a version installed previously? If the latter - did you fully delete the previous version? I’m thinking about duplicate library files / folders for example

No, it is clean install.

Restart and try to login as an other user.

No change, application is not responding when clicked.

Just guessing. Restart on safe mode?

1 Like

Something is clearly happening with application as it loops. Is there a way to check what is the problem? Maybe log of errors or something?

There are logs when it crashes but this doesn’t sound like it’s even starting. Have you tried Utilities>Disk Utility> First Aid on your hard drive.

Also, you could try repairing permissions - no longer available in Disk Utility but you can do in Terminal. Open Terminal - type: diskutil resetUserPermissions / id -u

Always worth ensuring you have an up to date back up before doing anything in Terminal.

Did you try starting in safe mode as suggested?


It will help eliminate other sources of problems.

OK, now it gives error regularly after several minutes of not Forcing Quit. Problem report is saved here https://controlc.com/e40701dd

Something for RealMac support
@dan @Aaron