RapidWeaver 7 freezes on startup [solved]


(Terry Vosbein ) #1

When I try to start RW7 on my MacBook Pro, it gets stuck in the open file window. All .rw files are greyed out. And if I click on open or cancel, it closes and immediately reopens the window. If I try to open RW by double-clicking a .rw file, I get caught in the same loop. The only way out it is to force-close RW.

I re-downloaded the app but the same thing occurs.

I have High Sierra and I recently updated some music software on this computer, and hadn’t started RW in a while (I work mostly from my iMac). Music software is famous for disrupting links and settings, so maybe something happened that interferes with RW.

Are there RW files in other places in my system that may be corrupt or pointing to places that may not exist anymore?

Does anyone have any ideas? I am about to hit the road for two months and need to keep updating my RW sites.

Thanks

Terry Vosbein


(Rob D) #2

Have you tried to drag a project file to RW icon in the dock before you launch RW?


(Terry Vosbein ) #3

I had not, so I just tried. Same result.


(Terry Vosbein ) #4

More testing. I created a second user on the laptop and rapid weaver opened fine. So something in the music software updates changed something in my system settings that causes RapidWeaver to not open. Or so it seems.

When I open RW as the new user, it opens as an unregistered app. That may because I re-downloaded the software, or maybe RW is only licensed per user, not per machine. I didn’t register it, just made sure it opened.

So worst case, is I can log into the other user account to update my RW sites.


(Greg) #5

I have had this issue a couple of times, both times after a reboot. Both times it was solved by logging off and logging back in again. Although I may have rebooted as well. The only out of the ordinary thing I have is my own location for the addons folder.

Running Sierra and everything in the rw world up to date.


(Leraillez) #6

I deleted all files and folders in my user/library. I moved all my files to another location and it finally worked. I think the one group of folders is the one found in “~/library/Group Containers” where I found two folders. Now it finally works. More than a week to find it (and two OSX reinstalls).


(Terry Vosbein ) #7

Thanks for sending me down the road I should have known to try myself. I deleted all files that related to rapidweaver in my library folder and elsewhere, downloaded a new copy, started it, registered it, and it is all up and running.

Thanks!


(system) #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.