RW crashes on v6 project upgrade; new v7 project also crashes RW


(Alex) #1

Hi.
Have an old file in .rw6 format I need to work on so ran RW7 which opened & created a new file. Made some edits & closed. Now every time I open the (new) RW7 version, RW crashes immediately. Tried re-opening the (old) .rw6 file to see if I could upgrade the file format again & crashes after few seconds whilst ‘Migrating Home…’ (having moved the RW7 version out of hte directory).

Have restored old version of .rw6 file from yesterday’s Time Machine (i.e. pre-update attempt). This also now crashes RW7 every time I open it after migration message. So… now have 2 versions, neither of which I can open as both crash RW within a few seconds.

Have upgraded to RW 7.5
Have uploaded both the .rw6 file & RW7 version in a zip here:
http://wellingtonicu.com/Data/temp/DM%20crash.zip

Does anyone have any idea why this may be happening?
Thanks!
(have logged multiple crash reports with RW just now)


(Isaiah Carew) #2

Hi Alex,

Sorry for all the issues. It looks like this file triggers a pretty bad bug.

Here’s the detail in case you’re interested
When you combine these ingredients: large file (many pages), large Stacks Library (many installed stacks), a file that needs to be migrated from RW 6, and a file that uses certain stacks (ones that rely on encryption libraries)… BOOM.

Of course it shouldn’t. And it’s definitely not your fault.

The good news is that your file was a perfect test case – and with that in hand – I was able to fix it very easily. Thank you so much for posting the real files – you can’t imagine how much that helps!!! :smiley:

I’ll be releasing a fix for this problem in a beta version by the end of day. And I’ll push that out to all users after beta testers have a chance to run it through its paces – probably just a day or two since the change is rather small.

If you’d like to grab the beta and help test – then you can jump over to our Slack channel – I’ll post a build there – hopefully in a few hours. http://slack.yourhead.com

Isaiah


(Alex) #3

That’s great. Thanks so much for your rapid response. I thought multiple pages/stacks may be contributing.
Will grab the beta; thanks for giving me my website back!
Alex
:grinning:


(Isaiah Carew) #4

Posted the beta just now. A few developers have already tested it and gave it a :+1: (including with RW6 migrations) so we’ll probably roll it out to everyone tomorrow morning.

Thanks again for reporting.


(Beto Boton) #5

Hello

I face the same issue.
I spent hours trying to fix the crashes while publishing without success.
I came up to the conclusion it is easier (hours to work on) to start a new RW7 project.

Some add ons did not like the RW7 conversion process.

Good luck

Beto Boton


(Gary) #6

I was getting instant RW crashes when trying open RW6 files. I recall seeing the latest beta on the Yourhead Slack channel and tried that which cured the issue. I have since opened several RW6 files in RW7.41 using Stacks 3.55b1 successfully. Thanks to Isaiah for jumping on this so quickly.


(Isaiah Carew) #7

This is out of beta and released to everyone now. There are a few more little fixes in there too.

If opening RW6 files is still causing problems for anyone we want to hear from you, just send your file to http://yourhead.com/support and we’ll give you a hand.