Safari shows an error message

When I choose in Safari the option ‘Developer/show page’s source code’ the following message appears:

Probably because you’ve got a URL misconfigured somewhere on that page

Make sure to remove the http:// from the website URL. In RapidWeaver there are two places to do that. General Settings >> Web Address field, and Publishing Settings >> Website Address field.

If the URL is configured somewhere specifically on that page, you’d have to locate it and remove the http:// part.

Hi Dan

Many thanks for your fast answer.
I don’t understand your recommendation completely. When I omit the http in the General Settings I receive this message:

Simple enough the hosting provider has installed an ssl for you change the webadress to the error should go away

Yep, just select the “Yes, use HTTPS” button from that screenshot you posted. It should update your URL in RapidWeaver’s General settings to, or you can update it manually if you need to.

Again, you will want to make sure the URL is set as in your Publishing settings as well. Sometimes there is a URL mismatch between those two areas in RapidWeaver which can cause problems.

Republish after correcting both those sections with the correct URL, and the issue should resolve itself.

Hi Dang
I did as you told me but I still get this message:

The console errors are gone so you solved the misconfigured URL issue.

Your blog looks kind of weird, why are you linking the individual articles to a Styled Text page and 3 separate PDF files when clicking on them? That’s not how the built-in blog should work. Are you using the built-in blog or a third-party add-on for the blog?

For the built-in blog we have a guide here that shows how to create blog articles. Perhaps follow along with that, it might help.

The consolidated CSS file is working fine. I don’t know what those “Extra Style Sheets” folders are for. The theme is from @MultiThemes, perhaps he can help.

Hi Dan

Yes, you are right. I abuse the blog page (of RW), but I have one reason to do that. The actual page shall be - after a while it has been posted - put in a archive, and as the blog page manages itself to maintain an archive, I thought it might be the easiest way to put the content of the actual page in a blog body. I see it’s not what you wanted to provide, but for me it works very well.
By the way: the error message of Safari can be produced on nearly every page, no matter which website builder was used.
Thanks again for your engagement.



Yeah, I was focusing on the blog because that was the only page throwing the console error. I still see those “Extra Style Sheets” folders on the other pages. I’m not really sure why they are there. Could be the way you’ve built the pages, could be something to do with the theme. Again @MultiThemes makes that theme so you can reach out to him perhaps. I don’t have the theme to test on. If you want to send your project over per our guide here I can take a look.

1 Like

@Dieter I’m not sure I understand the problem, if you PM me your email I can check. I any case in TILT you must use the option: Consolidate CSS files

BTW: make sure you are using the latest version of the theme, if you need any assistance let me know.

1 Like