SFTP no more working

My provider updated (06.11.2021) to OpenSSH-Version 8.8 which does not support RSA-SHA1 any more. The login failed. I used to work before that.
So I can not publish my website anymore.

Matthias

Have you tried regenerating your SSH keys?

I do not think, that SSH keys are the issue.
SSH-login to the server from the terminal works just fine.
This indicates that this is a RapidWeaver issue with SFTP.

Here the message from the Telekom server (in german): Homepage Center Hilfe: 21.10.2021 - einige veraltete sFTP Clients funktionieren nicht mehr

1 Like

I do also have this problem with two client sites which are hosted on a german Telekom server.

@dan Dan, is there s.th. you can do about this? Here’s the translation of the german article from the link to the Telekom post above:

21.10.2021 - SOME OUTDATED SFTP CLIENTS NO LONGER WORK
Since a few days, access with some outdated sFTP clients no longer works, although nothing has been changed in the settings.

This only occurs with programmes that are internally based on an outdated OpenSSH version. We have found this to be the case mainly with outdated web page creation programs with a built-in sFTP client.

Install a current version of your software. For programmes that are no longer maintained by the manufacturer, local publishing in conjunction with WebDAV access may be an option.

Background information:

On 06/10/2021 our sFTP server was updated to OpenSSH version 8.8. With this update, support for RSA-SHA1 has been dropped. This algorithm has been outdated for many years and alternatives have been offered in OpenSSH for many years.

The problem therefore only occurs with software that internally uses an OpenSSH version that has not been updated by the manufacturer for more than 5 years."

@RapidBase I’m just speaking with @tpbradley about this — Will give you an update on the plan shortly…

2 Likes

Thanks Dan. I want to add that the connection with Transmit 5 works flawless (with the same settings).

We’ve looked into this and RapidWeaver should work (we’re using the correct version of OpenSSH).

Can you guys try and regenerate your SSH keys and see how you get on?

Thanks,

Dan

Thanks Dan. Never ever have done that. So must have a look when I have the time how a SSH key can be regenerated and where I would have to put this into the publishing settings of RW.

Wondering why Transmit doesn’t need this…

Or the Terminal program. This does indicate the SSH key is not needed.

Matthias

Hi guys,

It would seem that this is a far more complicated problem than we originally thought. Please bear with us while we investigate further.

Cheers
Tom

3 Likes

@RapidBase and @mgott Do you want to give the newly released RapidWeaver 8.9.3 a try? It should fix your issue!

You can get it via in-app update or download it directly from the release notes page.

1 Like

Yes, the fix 8.9.3 did work.
Thanks a lot.

3 Likes

Yep, all fixed now! :slight_smile: Big thanks to Dan and Tom!! :+1:t2:

2 Likes