Site wide code - publishing


#1

When I apply site wide code (CSS), on preview it works as expected. When I publish however, the changes do not take effect.

Is there something I’m missing? I have tried publishing all files as well with no effect.

(Running RW 7.5)

Thanks in advance


(David) #2

Have you tried clearing your browser cache and refreshing the page?


#3

Yeah, still no luck. All my other page per page changes occur, just not the site wide code.

I know the css code is valid because it does work in preview


(David) #4

Can you post a url?
(more characters).


#5

@thang

http://www.kingsdale.com/kah/boarding.htm

The H1 tags should have a text-transform:uppercase

Thanks


(David) #6

Yeah, I’m not seeing that CSS on that page.
When i tried this in the browser page inspector it did work:

h1 {
text-transform: uppercase;
}

Does it work when you try it on the per page CSS?


(scott williams) #7

If it’s in site wide, did you republish all files?


(Pete Schuder) #8

Could there be a problem with 7.5 not publishing updated files or actually all new files? I had to use FileZilla to get all my files on my server as 7.5 would not work for me in uploading newly created stacks. Went back to 7.3x


Help with small CSS override
#9

Yes, the code works if I put it in the page CSS. I’ve also tried republishing all files.


(scott williams) #10

I just had a look and the text-transform CSS is not making it to the page.
So either there is;
a publishing issue (the update is not being published) - can you export and ftp the site to find out?
a cache issue ( the server is not serving the new content) - are you using cloud flair or similar?
the CSS change is not being implemented for some reason - this seems unlikley if you can see the change in RW preview.


(Robert Ziebol 🖖🏼) #11

Is it possible your page filename changed from .html to .php and you are not seeing the changes???


(David) #12

I just tried a test with RW 7.5 and this CSS snippet was successfully uploaded and worked as expected when the CSS was in the site-wide code, as well as when I put the CSS in the page inspector code box.

So it appears that this is not a universal problem related to the version 7.5 update.


#13

Thanks for all your assistance. I uploaded to my live folder on my server and it seemed to work. Not sure why it wouldn’t work within my test folder. I did check and there were no duplicate pages, i.e. one html and one php