RW 7 Changes won't Publish - Siteground Host

Frustrated! I’m trying to publish changes but they’re not showing up. I’ve been working with Siteground to solve but they think it’s a RW issue. This started when I added “force http” on Siteground and also activated Cloudflare and I cleared cache with them. Siteground is not solving. Can anyone tell me how to fix? I have a very simple site. Novice here. Can I talk to someone directly on RapidWeaver???

Hi Mary and welcome,
I think we would need a little more information to help you out.

  1. Did everything appear to publish okay when you made the changes?
  2. Could you provide us with a URL to the site and a description of what you changed?
  3. Have you tried to turn off CloudFlare (Turn on Development Mode)?
  4. Is CloudFlare setup through your hosting company or directly with CloudFlare?
  5. Have you tried checking to make sure the files got to the proper location with site grounds file manager?
  1. Yes, all changes said they were published
  2. - i want to tell you that about 3 months ago I started seeing “not secure” in the url and when I asked Siteground about it, they said to turn on “force http” button, which I did. after that, I started having issues. not sure this is connected to my publishing issues.
  3. I just turned off CloudFlare within Siteground
  4. Yes, CloudFlare is setup through Siteground.
  5. No, haven’t checked that.

Have you tried switching that back off?

If RapidWeaver doesn’t give you any error messages when you publish then the files are probably getting put somewhere. Could you give us a screenshot of your publishing settings?

My next step would be to check the server with either an FTP client(Transmit, FileZilla, etc) or the file manager at siteground. Check the date to see if it changed.

Again, novice here so maybe you can detect the problem looking at these folders.

I also turned the “force http” button off and on and it didn’t make a difference.

It looks like you have possibly published to the wrong path.

Don’t know for sure as I don’t have any experience with this hosting company, but you have what looks like your RW published files in the root directory of your account.

… etc, etc

But you also have a directory called public_html. I think that’s where you should be published into.

I also noticed a directory called home and the lack of any index.html file. Are you using tidy links?

1 Like

Siteground confirmed When the files are updated ( or if you upload brand new files ) - they are automatically stored within the public_html and the sub-directories of the site there, depending on how the site is built.

I’m at a lose as to why I can’t see my published changes?


Could you give us a screenshot please of the RW publishing settings?

Judging from the file manager screen shot you have above, I’d say you are not in the publis_html directory but are in a directory called There is a public_html direcotry in that directory along with direcotories like like rw_common and files that are more than likely created and published by RW.

I think who every you are talking to at Siteground is talking about there file manger upload or something else. All there FTP tutorals show you having to choose public_html.

1 Like

Also, I moved site to RW 8. When I Preview changes in Safari - I see all my changes but I don’t see them when I publish the files. Siteground said this is an issue with RapidWeaver

It’s really hard to say what is going on,

I look at that screen shot from the file manager and I see underneath the main directory public_html (directly below the public_ftp) directory, and then further down the picture I see another public_html.

Without seeing a more complete list of what you have out on the server and without knowing is supposed to be out there it’s just guessing.

I don’t have any experince with Siteground, but loking at there online help, it looks like you they only show one public_html folder directly under the host folder. I can’t tell if the top one is or the one at the bottom of the page is the one you need.

Is your site all Rapidweaver?

Do you have any CMS’s or warehoused stuff?

Could you get us a better screenshot of the files showing what’s below the .htaccess?

Could you try Clearing the path in Rapidweaver and hit the Browse button. That should give you a a list (and take a screenshot) of directories and files on the server.

Can you instruct me how to do this?

Could you try Clearing the path in Rapidweaver and hit the Browse button. That should give you a a list (and take a screenshot) of directories and files on the server.

Under publishing settings, there’s a field called path, clear out (delete) the data you have in it and hit the Browse button right next to it.

I host all my clients’ websites at Siteground, force https and I haven’t had the problem you describe.
Also, I remember that to activate Cloudflare via Siteground you need to change to www (this could cause the issue).

Here is what I see when I hit browse including what is in each folder. Should the folder be there?

Okay, so the directory public_html (the second screenshot) appears to be the one that is being displayed on the internet. I can tell that by the subdirectory names and what is being shown at the URL.

So my guess is the path you previously typed in isn’t correct (it might be the / at the beginning). So from that browse the screen I would select the public_html directory (don’t type it).

Then republish all files.

Still not working. My user name and password in the publishing settings use to be diff. and then Siteground changed it to the current username/password. Should I try going back to what I use to have?

If you are able to connect (The test button or the Browse button works) then there isn’t anything wrong with the password/username.

So from this screen you selected public_html?

What does the path look like after you selected public_html?

On this screenshot:
There is another public_html directory, could you give me a screenshot of what’s in it?

  1. When I select the public_html folder and publish, the path reads - /public_html.

  2. When I go into the folder, and highlight public-html… these are the subfolders.

That’s it.

I bet That’s the one that you should have been using.

  • Select that public_html inside the directory.
  • Republish all files

That makes sense now. You’ve got quite a bit of a mess out on the server that should be cleaned up.

Try that directory and if it works (after clearing the browser cache) report back and we can figure out how to clean things up.

1 Like