Code not uploading/changing in Head


(Cynthia Taylor) #1

Hello,

I am trying to replace a script I have in the Head area of a website with RW7. I deleted the old script, where I went to Settings, Code, Head. I then replaced it with the new script. When I save and publish a page, the old script is still there, so the new one doesn’t work. Is there anything else I should be doing to make the new script work? Thank you!


(Rob D) #2

Hi, @cynthia
It sounds like you may have both older and newer version of the same page on the server.

Use any of the 3rd party FTP applications (i.e. Transmit or Yummy, or some other app) to remove older version from the server. Better yet, delete all files and republish. I hope this helps…


(Cynthia Taylor) #3

hi there,

I tried that, but I didn’t see another copy of the file on the server. Even when I deleted the file and republished, it still didn’t work. What I did was to delete the file, and upload it again using Transmit with the correct script in the code. That worked, for now, but I know that I can’t ever republish with RW because it will put the old script back. I wanted this script throughout the site, but I guess RW won’t let me do it. Thank you for your suggestion!


(scott williams) #4

This sounds like a bug in RW publishing. I would let support know especially if you can reproduce it. It may help them squash the bug if you send them the project file. Hopefully @dan or @ben will see this.


(Cynthia Taylor) #5

OK, it sounds like you’re probably right. Thank You!