Sitemap 2 question

Just wondering if I’m missing a checkbox or something on a page I want hidden from Sitemap 2? The page in question is being used a landing page in a geofencing campaign. The following conditions are set:
RapidWeaver project:
• Advanced > Generate Search Engine is unchecked (I’m using Sitemap 2 instead)

On page in question:
• Show in Navigation is unchecked
• Enable Robot Meta Tags is checked
• Index this page is unchecked
• Follow links is unchecked

In Sitemap 2, the following are checked:
Site Organization > Hide in Sitemap > page is checked
Search Engines > Disable Search Engines > page is checked

I’ve deleted the sitemap using FTP to be sure a new copy is being generated, but it continues to show up when Sitemap 2 is republished. Screenshot below is just prior to manually deleting the page in question (Asheville)…


To remove it from the XML file you check the Disable Search Engines box. It seems like you have the right thing.

“Hide in Sitemap” removes it from the the table of contents style site-map page – the one that users can see.

I think the first question I have is what version are you running. There are some significant incompatibilities with the older versions of SiteMap and the most recent versions of RapidWeaver.

1 Like

Thanks, Isaiah! I’m using version 3.1.0, dated January 23, 2019 (and, it’s licensed). I think I originally bought it about six years ago when Loghound was still making it. What’s really weird is that the page right next to it, that contains code I recycle, doesn’t show up in the XML file. Could it be because I have two pages, in different areas of the site, that are named the same?**asheville**/ (used as a geofencing landing page)**asheville**/ (the “real” page for the Asheville location)

EDIT: My codepage doesn’t get published, so I can see why that one won’t show up in the XML file. Still, I wonder if having two final folders named Asheville is causing the issue?



it really shouldn’t cause any issues. i think perhaps the best way forward is for me to get a look at this file – or at least some part of this file. if you like to send me something chopped down without GB of resources that would be understandable (and appreciated). the only key part is that whatever you do send me still exhibits the same issue.

i should be able to have a look at exactly what’s going on and let you know – or if there’s a bug it’ll give me a solid example to identify it and get it fixed.

just zip up the smallest version of the file you can create, share it on dropbox (or your favorite file sharing service) and send the link to me. you can send it here as a private message, or via slack ( or our support email (link on my website).


Thank you, sir. I’ve sent a download link via your Slack channel. All the best, Dave

Just wondering if you’ve had time to look at this, @Isaiah. I understand if you haven’t - I know you’re busy with S4.

Oh, sorry about that Dave,

Got caught up debugging Stacks 4 thing this week and lost track. I apologize.

Open the Settings and in the first tab, near the bottom, select the option that says “Hide page marked with ‘Don’t Show’”

I suspect that (in combination with your other settings) should make the checked items disappear from the XML file. I did that and it seemed to do the trick for me with the example that you sent (and thanks – that made the issue crystal clear).

I do think that the combinations of these three settings of the various ways to hide/show things in the XML file and/or the Table of Contents page makes this stuff far harder than it needs to be. These are the options that everyone wants to fiddle with – yet they’re at the same level as the crazy stuff that hardly gets used at all.

I did a minor UI cleanup 3 years ago – but didn’t really re-think any of these things. I think it’s about time. This example really highlighted that. :yum:

Many thanks, Isaiah! That worked.

Very much looking forward to Stacks 4. :slight_smile:

I other item I’m seeing that’s probably due to user-error, but it’s an important one since it keeps Google from indexing the homepage…

I’ve noticed that the homepage is getting an extra “./” in the sitemap. In Rw, I have the following set:
Homepage Inspector
• Folder is left blank (if I put a “/” there, Rw gives me a warning, and then removes it)
• Filename is index.php

Advanced settings
• Tidy Website Links is checked

Here’s a screenshot of the sitemap that gets published. Ideas?

1 Like

the setting at the top of the advanced settings page: File Links are Relative to:

what do you have that one set to? same as in the example you sent?

Yes, correct. The settings are the same as the file I sent to you (I was pretty sure this one was user error!).

actually i do think you’ve found a bug on this one. i don’t have an explanation for why that’s there – or a way to make it go away.

my guess is that a change in the website url has snuck in to the rw api recently and i just didn’t notice it.

thanks for the tipoff. i’ll see what i can do to fix.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.