Solved :- I am finding it impossible to FTP?


(tim parsons) #1

I am finding it impossible to use RW to publish my Projects. it could be a problem with RW or it could be a general FTP problem. Using a FTP App doesnt help either.

I am asking if there are any BASIC tests i can do to establish where the actual problem is ?

I can then hopefully confront my Internet Provider with some concrete evidence !

PS. on the very odd occasion it does connect with my FTP app it is very painfully slow, i am wasting so much time going round in circles and getting nowhere.

Tim


(Mark Sealey) #2

Tim,

If you experience the same failures with both the built-in RW ftp routines and a separate dedicated ftp client, the chances are good that it’s something amiss either with the settings or with the host.

Which client do you use and which error messages do you get?


(tim parsons) #3

@MarkSealey Hi Mark, i have web space at three different Hosts, Chillidog, JustHost and Byethost. I also use YummyFTPpro.

As for error messages, a majority of the time it simply Times Out.

I have already had a lot of tips from Greg, I have now posted the same question on my Internet Providers Forum, I suppose i am clutching at straws, because i dont think my Internet Provider has any control over MY FTP problems.

and as for FTP settings, they have been working perfectly for years, until a few days ago.

Tim


(Mark Sealey) #4

Tim,

Logic would suggest that something has changed - either with your ISP or, less likely, all of your hosts.

With any luck, a look in Console (/Applications/Utilities/Console) - especially while you’re actually trying an ftp session and it’s failing - might give you some idea of what could be happening.

Could your local settings have changed (e.g. from ftp to sftp or vice versa; to or from Passive ftp etc)?

Have you upgraded anything else on your system?

In view of your last sentence, I’d suggest this is a network change/problem given that connections are failing across various environments.


(tim parsons) #5

@MarkSealey Thanks Mark, Logic must be spot on, but i dont know what has changed.

Console sounds interesting, if i can find it and understand it i shall have a go at that, but the day/night has now come to an end for now, and i wont be able to investigate anymore until tomorrow afternoon !.

Thanks again Mark

Tim


(tim parsons) #6

@MarkSealey Hi Mark, i have spoken with a knowlegeable chappie at Plusnet, my Internet Provider, he assures me everything is ok at his end.

I found Console.app easy enough and ran it, lots of stuff scrolling up the screen pretty quick, but of course i dont understand a word of it :frowning:
is there a way to make the output more selective ? for example :- only show stuff applicable to my internet connection.

Tim


(Mark Sealey) #7

Tim - Yes. in the top right corner of the Console select to display only results from your ftp client.

Then try an upload to each of your hosts in turn using that software and see whether Console’s results have something in common.

You could do the same thing with RW (similarly filtering on ‘RapidWeaver’ in the Search box top right) as well; but to eliminate other variables, the FTP client which you know used to work is a better starting place.

Open Console, enter the ftp software’s name and then try an upload etc.

Note that the names of the logs (=places on your system) which are monitored in the side bar on the left vary from OS to OS, so suggest choosing the closest to ‘All (Reports?)’.


(tim parsons) #8

@MarkSealey Hiya Mark, i do appreciate your help on this, i am sure that Console will give me the required info, but the procedure does look a bit too complicated and i wouldnt know what to do with the information anyway LOL. (i will make it a last resort though, just before i throw my Lap Top in the bin !!)

I have been having a lot of help from Greg @ chillidog he says i am typing in the wrong credentials and I will get my IP address banned

What i tried today, i created a new User Account on my Lap Top and believe it or not YummyFTPpro did work ok in that, uploading to a freebie Web Space, not chillidog !, with no problem.

I also installed a trial version of RW but with none of my projects or stacks available that was a waste of time.

I wonder is there a way that i can share my registered version of RW7 with this new User Account ?

Later :- dam me it just isnt my day today !

i dont have anything to select in the top right corner !!!

Tim


(Mark Sealey) #9

Tim,

In the top right hand corner (thanks for the screen shot) where the little magnifying glass is to the left of the word ‘Search’ you should type ‘YummyFTPpro’ and then start an FTP session. Note any messages that you get if it fails.

I’d pay attention to what Greg says: credentials (login or user name and password) are likely to be case sensitive. It is vital to get them 100% correct or failed login attempts like the ones which you are getting will result.


(Rob D) #10

Reading your P.S., I thought it would be worth reminding ourselves that depending on the kind of our Internet access and the time of the day, the congestion of the traffic may become so bad that it slows down very significantly. This may be even the reason for cutting off your uploading.

Of course, all other comments are still very valid…


(tim parsons) #11

@MarkSealey @Rovertek Hi all, thanks for all your advice and tips and recommendations Lads, I still dont know what really changed or what i did, BUT it all came good a little earlier and i am now back up and running :slight_smile:

Boy o Boy am i pleased

Tim


(Jason Bostick) #12

For whatever reason, I’ve often wondered if this is an issue and if perhaps RW’s publishing has less tolerance for slower connections than the FTP apps. Nothing really to back it up but just a hunch I’ve had over the months of people reporting issues…


(Mark Sealey) #13

Jabo, Rob and Timmy - with all the asynchronous bits and bytes whizzing along the wires simultaneously from billions of devices around the world it’s a wonder that any of it works at all, isn’t it.

Glad you got it working, though. Good luck!


(tim parsons) #14

@Rovertek @MarkSealey All credit must goto Greg at Chillidog, he kept his patience with me all the way through my tantrums !!!
I dont really know why it all went wrong for me, although Greg suggests it was a typing error on my part !
I often wonder to, about how on earth does the WWW cope with all the DATA whizzing around and when it IS all working OK, it is amazing how quick it works, considering that the World is so darned big as well, Data takes only milliseconds to travel, for example, from the UK to the USA , where i think most of you chaps live !!
Come to think of it now, i did start a thread that asked members to Post where they lived, i wonder what happened to it ?

Tim


(Greg) #15

It’s odd. I have an appallingly slow and unreliable internet connection but never have publishing issues via RW. The only other ftp clients I use are “Fetch” and the ftp command line. All work fine albeit sometimes rather slowly!


(tim parsons) #16

@barchard It did me a big favour eventually, as GREG of Chillidog, suggested i use SFTP and it all seems to Fly along now !.

Tim