Stack Embed from Stacks4stacks.com


(Dmitry) #1

Dear gurus! Firstly, forgive my English.
I just can not configure the Embed stack. I’m trying to create a website with lots of pictures (these are illustrations of children’s books that I was preparing for printing) and they are quite large. Here is the sequence of my actions.

  1. In the RW project (3.5.2), I create a new Stacks page.
  2. In the specified field, I put the Embed stack.
  3. In the Transmit program, I create the Assets folder and load several files into it.
  4. I set permissions on the folder - 755, on files - 644.
  5. In the Embed stack settings, I select “Images From A Directory” and specify the path to the folder that Transmit gave me “ftp: //XXX.XX.XXX.XX//portfolio.scansione.ru/www/assets
  6. I select the png format and try to publish it all.
  7. Here is the answer of the published site “Directory” ftp: //XXX.XX.XXX.XX//portfolio.scansione.ru/www/assets’ not found! "
  8. Tell me, please, how the path to the repository should look. And maybe I’m still doing something wrong. Correct me, please.
  9. With sincere respect!

(Doug Bennett) #2

Not sure where you’re getting that path name. Looking at your file directory it appears that you have a www directory inside the main directory, and the assets folder is inside that.
The file path you’ve given shouldn’t have to sets of double slashes //. Try dropping all the XXX.XX.XXX stuff and start with the second set of double slashes.


(Dmitry) #3

Thank you for answering me.
ftp://185.84.108.16//portfolio.scansione.ru/www/assets - this is the way that Transmit gives me.
How do I convert it to insert into the stack settings?


(Greg Schneck) #4

the “www” is your main web root directory… you would point beginning with /assets/ being your first folder. Assuming your stack is asking for a URL the path would be http://portfolio.scansione.ru/assets/


(Will Woodgate) #5

Whatever Transmit gives you will be wrong. This needs to be a relative path, not an absolute path. A relative path never starts https://, http:// or ftp://.


(Dmitry) #6

Thank you very much for your time.
But something I can not do :frowning:
I decided to do everything from the beginning.

  1. Created on the provider’s website a new subdomain “test.scansione.ru
  2. In the program “RW” created a new project with the page “Stacks”
  3. In the “General - Advanced - Default Extension” settings, I installed “php”

20

  1. The “Page Inspector” tab was configured as follows:

35

  1. Accordingly, in the settings “Embed” prescribed the path:

  1. The following screenshot shows the structure of the folders on the provider’s website:

  1. On the “Edit / Preview” page this did not cause absolutely no response :frowning:
    And after the publication I have: http://www.test.scansione.ru/

(Stuart Marshall) #7

Try it with just: images/


(Dmitry) #8

Wow! It worked!
True, every image has a signature:
Strict Standards: Only variables should be passed by reference in /home/u172786/test.scansione.ru/index.php on line 102
Thank you! I’ll cut further :slight_smile:
Once again, accept my sincere thanks. You are best!


(system) #9

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.