Stacks causing jumping to top of page on desktop but not laptop


(Lisa Sandler) #1

So I’m well aware of the issue that some things in stacks will cause the page to jump to the top when editing (Jumping back to the top).

I’ve been working on my laptop just fine for the past few months with none of this happening, including a few days of working in RW8.

I just copied everything over to my desktop computer and have not changed anything. It’s now constantly doing that annoying thing again when I’m editing text in a stack! What has changed and why should this happen now? @isaiah ?

thanks


(Lisa Sandler) #2

Ha… I think I figured it out. I had font resources that were linked via warehousing on my server and called from Instacks Custom Font stack and somehow didn’t carry over in the copy. Even though I wasn’t using those fonts anymore, the stack still made the error.

See there, people! I didn’t just blame everything on RW or Stacks and rant how horrible everything is, I posted, then worked through it. User error, as admitted, with a solution :slight_smile:


(Joe Workman) #4

Loading external resources inside Edit Mode will cause the “jumping”.

This is why my Font Pro stacks do not load fonts in edit mode unless you check a button that allows it. It then displays a warning about the jumpy edit mode so that you remember to turn that off. :slight_smile:


(Lisa Sandler) #5

@joeworkman can you explain more? I thought I solved it with the font thing, but it’s still jumping on some pages. This did not happen on my laptop at all. It just started happening when I switched to my desktop. I’m not using anything to call fonts except site styles in Foundation. I have no resources to load at all.


(Joe Workman) #6

What I mean is if a stack is loading any files (css, images, fonts, etc) from the internet it will cause jumpiness. Stacks should be loading resources locally from your machine. A.K.A. the stack should be self contained and ship with everything that it needs


(Lisa Sandler) #7

Ok, but that doesn’t answer my original question. Why would it happen on one computer but not the other?


(Joe Workman) #8

Different versions of the stacks installed? I was just letting you know what I find being the most common cause of the jumpiness.

I should clarify what I refer to as jumpiness… when you add a new stack to the page, the Edit Mode UI will jump to the top of the page.


(Lisa Sandler) #9

Ok. I copied and replaced my Addons folder. Should be the same.


(Isaiah Carew) #10

the jumping you see is caused by Stacks re-rendering the page but is not able to locate the place in the page where it was before the render began.

this can potentially be caused by a lot of different things, 99% of the time it’s one of two things:

  1. bad content
    “bad content” is anything that mangles the HTML. the most common thing I see is when someone uses a snippet of HTML they found on the web, perhaps for analytics or something similar, and missing a character or line off the end when copying. the result is an un-closed <div> or similar. this could also come from styled text copied and pasted from an external source.

    Solution: look for anything “weird” going on on the page. if you have entered any HTML on the page, triple check to make sure it is free of errors. make sure to alway Cmd-Opt-V when pasting – which pastes and clears styles.

  2. super slow
    if the complete render of Edit mode gets to about 5 seconds then Stacks gives up and just scrolls to the top of the page.

    Solution: the only solution is to simplify the page to make it faster. at that point it may be a good idea to simplify the page anyway – a slow page in Edit mode often indicates a level of complexity that will affect the people visiting your site as well as your Google rankings.

If you can’t find either of these things, then it’s time to contact YourHead support and share your project file via DropBox with us. We can take a look at it here and give you a better idea of what’s happening.

Isaiah


(Lisa Sandler) #11

@isaiah it’s not going slow in editing, and the weird thing is it’s fine on my laptop (no jumping) but not on my desktop. I copy the add-ons folder and the RW file from computer to computer.


(Isaiah Carew) #12

Can you share this page with me. With the file in hand I should be able to tell you exactly why it’s happening.

If you like you can log in to slack http://slack.yourhead.com and let me have it there or you can send it to http://yourhead.com/support (which takes a bit longer, but also works).

Isaiah


(Lisa Sandler) #13

thanks, will do.


(Robin Mair) #14

For what it’s worth I have been seeing this problem a lot today. But then I quit RW8 restarted and opened a different project and it was working correctly. Then opened the project that had been jumping around and all of a sudden it is now working correctly.

Very disconcerting!


(Isaiah Carew) #15

@handshaper The details I gave for finding the bad content above should work for anyone on any document. And if you need help finding it, the offer of assistance is open to all. :smiley:


(Robin Mair) #16

Thanks, Isaiah! I’ll keep working with it and if the problems return I will send over the project, I have no idea why the problem simply went away with a restart, very disconcerting.


(Isaiah Carew) #17

@handshaper - :+1: as projects gets large and contain a wide array of content from a variety of sources, there is more chance of introducing something that causes issues.

stacks does do some work to contain content problems, but sometimes the problems are too disruptive.

and, of course, if the page is slow to render due to many stacks, then there may be nothing left to do but simplify the page or buy more memory.


(Robin Mair) #18

Understood!

Actually I was in the process of drastically trimming down on the number of stacks being used on the page. Maybe it was just the case that I got it down to a reasonable number and that solved the problems, we’ll see!

Thanks!


(system) #19

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.