Stacks drag and drop not working


(Michael Lever) #1

RW 7.0.1 Theme: Wilderness 5 (latest version), Stacks 3 (latest version). All stacks updated.

I duplicated a page of stacks, deleted the unwanted stacks, but cannot add new stacks. So I added new stacks page and tried that instead. Nothing. Clicking the stack in add-ons responds, but when I drag and drop the stack onto the page, nothing.

Before encountering this problem, I’d been using another stack without any issue. I’ve tried closing RW7 and open again, but nothing. I do hope something hasn’t happen to corrupt the whole project,

Any suggestions? Thank you.

ps - Opened a different project, again nothing.


(Isaiah Carew) #2

So, first off, it would be helpful to know the exact version of Stacks. Sometimes folks don’t update and “latest” can mean something quite out of date. Double checking is always first order of business.

You have a lot of things tried, but it seems like we should start with something simple and then build up from there. Guessing at the problem/solution with so little info probably will only send us off in the wrong direction. So let’s try to gather a bit more info with some simple experiments… Try this…

Start fresh:

  1. Quit and Re-Launch RapidWeaver

  2. Create a new project.
    If the old project auto-opens then close it first – and Re-Launch and create a new project. The idea is that if there is something corrupted about that file, we’d like it not to interfere with our experiment.

  3. Add just one Stacks page.

  4. Drag a built-in Text stack to the page.

  5. Preview.

Does this work?

  • If the answer is YES, then we can move on to a more complex experiment. Like opening your existing project file and seeing if that works.

  • If the answer is NO, then something is fundamentally wrong with Stacks, RapidWeaver, and/or Mac OS X – and we should try even simpler things: reinstall everything from scratch, reboot, etc.

Let me know how the first experiment goes and we can move on and see if we can figure out the next step.


(Michael Lever) #3

Noted, thank you

Stacks 3+

I solved the problem, What I was trying to do was drag and drop from the addons, not the library.
I don’t understand why have two places for the addson, so perhaps you could explain.

Michael Lever


(Isaiah Carew) #4

why have two places for the addison

Stacks has always had a Library (since 2009!) from which you can drag and drop, organize, and see all of your stacks and images. Two years ago RapidWeaver 6 added an add-on manager, primarily as a way to see all of the different sorts of addons (plugins, themes, snippets, and stacks) that you have installed. This “new” (ok, 2 years old is not exactly new – so maybe “newer”) add-on manager doesn’t have the necessary features to replace the existing Stacks library – so the Stacks library remains as well.

Short answer: The Add-on Manager is for managing all of your addons. The Stacks Library is just for Stacks.

Stacks 3+

Also… I won’t beat a dead horse, because this issue seems solved. But in the future, giving the exact version number will help solve problems much more quickly as things really do vary quite a bit version to version.
The exact version number looks like v3.x.x and you can find it in the Add-on Manager


(Michael Lever) #5

Thank you.
I shall remember to state the exact version. Even though whenever I say ‘latest version’ that is what I mean.


(Robert Ziebol 🖖🏼) #6

Hey @mog1 doing support for Joe, I have MANY times had people tell me that they have the latest version of this or that, only to find out, they don’t. Isaiah is just trying to make it easier for us to help users like yourself and the best way to do that is to know the correct info.

The Addons Manager is a GREAT place to get info on your installed Plugins and Stacks, although, the Stacks plugin does an AWESOME job showing you the version number and giving you lots of places to even go and learn about your installed stacks, see below:

Anyways, glad to hear you got your issue fixed!!