Stacks installation fails


(Walter Merckx) #1

I’ve done a clean reinstall of rw7 and had to reload all stacks. I used the double-click option and got the confirmation stack installed. Reopening the application no stacks (apart from those installed automatically with the stacks plugin) can be found. When i redo the double-click installation i get the message “stack already installed”. So i did a manual installation, moving the stacks into the stacks folder and problem solved. I guess rw is moving the stacks to another folder or directory somewhere on my mac. How can i found out where and how can i adjust the destination folder within rw ?


(Doug Bennett) #2

Do you still have an old version of RW installed? A lot of us have had problems with the double click installation method. I think the easiest approach that seems to work without problems is to have RapidWeaver running, and drag the stack(s) onto its icon on the taskbar.


(Greg Schneck) #3

Another method that works well for me. Open your Stacks folder. (In RW stacks pane click the “Library” gear at bottom and “Show Stacks Library in Finder.”) Once you have the stacks library open in Finder quit RW and drop in the stack(s) manually. Verify your stack is in the folder. Restart RW.


(Robert Ziebol 🖖🏼) #4

The best way to get to your Addons folder is to open RapidWeaver, then hold down command+option and push 7. That opens the RW Addons folder, then find your Stacks folder and open it. Drag and drop stacks in there. I keep the Stacks folder in the sidebar of my finder windows, so I have easy access to it all the time.


(Ken) #5

@waltermerckx Have you tried using the menu option (in RW - first dropdown list) to copy addons to rapidweaver 7 - this was designed to accommodate the upgrade. If you’ve still got RW on your system with all its addons/themes/stacks this will do the job (if not you’ll need need to manually reload). Also if you’ve got both versions on your system and try opening an rw6 project within RW7 it will do a complete conversion and save you a new project RW7 file.


(Walter Merckx) #6

My rw application is up to date. Problem is that double clicking the stack the installation seems to be ok and I get the message “stack installed”. Reopening the rw application, only the stacks included in the stacks plugin are installed. When i do the double-click reinstall of the same stack, i get the message stack already installed. That’s why i had to install the stacks manually by dragging them to the stacks folder in the application support. Next time i will try to drag the stack onto the rw icon and will let you know (but honestly i think result will be the same as with the double-click installation because suppose rw puts the stacks in some other file)


(Walter Merckx) #7

Thats exactly what i did when the double-click installation did’nt work. But this is not how it should be .


(Doug Bennett) #8

Yes I understand that you’re running RW 7. Many users leave the older RW6 or earlier on their Mac, and the double click install to that versions location instead of the RW 7 location.
RapidWeaver changed the add on location with RW 7 so I would guess thats why it thinks it has installed correctly.
Your best bet is to not do the double click install and instead use one of the methods above.


(system) #9

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.