Stacks not working


(Peter Wepplo) #1

I am not very computer knowledgeable, so I may have created a problem that goes back to an earlier version of RapidWeaver. I don’t recall the first version of Rapidweaver that I started with, but I’ve progressed through several versions, though not necessarily using them all to update my website entirely.

So, I wanted to redo my website with version 6 of RapidWeaver in which I wanted to include links to a lightbox. I investigated several addons and purchased CosCulture’s Responsive Lightbox. However, I was unable to get it to add to a stacks page. Now, I want to take a step back. I had been using v6.3.6 and RapidWeaver suggested an upgrade to v6.4. Attempts to upgrade failed. I’m taking this to indicate there may have been something wrong with the software. Aaron in Realmac support gave me the update to v6.4 after I deleted v6.3.6.

Reboot (OS X 10.10.5) and restart RapidWeaver v 6.4. Still doesn’t work. Why do I think there is a problem?

Okay, I have purchased a Stacks addon. However, they cannot be added. I can see the addons, but most have generic icons, suggesting there is a problem with them.

I am puzzled as to what I should do to resolve this. Although this could be an add-on issue, since all add-ons are misbehaving, it seems more likely to be due to an issue with RapidWeaver. I have been going back and trying to remove vestigial files associated with an earlier version of RapidWeaver, but as I’m hoping someone may know, I don’t even know where all of the files are located. At this stage, I may be willing to cannibalize all versions of RapidWeaver and try to start over. A problem with doing so is that even when I deleted v6.3.6, I still had themes, addons, etc. in various locations.

Can anyone suggest how to get Rapidweaver working as it should?


(Mathew Mitchell) #2

I probably won’t be able to help you full due to time constraints I face today. But as a quick check:

  1. you have the Stacks plugin? (It is a paid extra to RW.) It is installed?
  2. What you image shows are “stack lets” (things that go on a stacks page, but ONLY on a stacks page)
  3. The image you show is not so helpful (I think): what happens when you are on a Stacks page and you try to drag a stack from the Stacks library onto a page? (Note: this is impossible to do is you don’t have the Stacks plugin)
  4. Put differently, do you see the stack lets in the Stacks library pane?

It’s hard for me to know at this point if the problem is user error, some sort of mess with the software, or a bit of both.


(Peter Wepplo) #3

I can create stacks just fine with the v3.1.0 of Stacks, text, Markdown, images, columns, etc. I just cannot do an addon with it.

Source of the error? User, software or both? Me too.


(Jürgen Schulze) #4

By default, addons cannot be placed on stacks pages unless you use addons like pluskit. (http://yourhead.com/pluskit)
Stacks go on Stacks (which itself is a plugin)
In order to use an addon, choose “add page” and select your plugin.


(Peter Wepplo) #5

I can add a stacks page and on that page is a box that says, drop stack here (or something like that). If I click on the ‘addons’ button, it brings up a menu with several icons. I can drag these onto the page, the menu disappears and no other change occurs. No addition seems to have taken place. I suspect there is some issue with how the stacks are being added to Rapidweaver as the Stacks icons are mostly generic. They do not have the appearance of the icons shown in the CosCulture stack (or anyone elses) that I’m attempting to incorporate.


(Mathew Mitchell) #6

Where you are off is by clicking the Addons button. That simply gives you a preview of all the addons you have for RapidWeaver, but it’s not “functional” on a Stacks page.

Instead look at the top left area (below the tool bar that contains Media, Snippets, Addons) and you’ll see an icon that says Library. It’s a little cube. Click on that and it opens … the Stacks library of elements. Now drag/drop onto the stacks page any stacks you want to use. Use one, use many: your choice.


(Peter Wepplo) #7

Thank you Mathew, that was it. However, in my case, there was more to the story. I had tried that with my version 6.3.6 and no addons were present. But, my version 6.3.6 would not update. It would download 6.4, but the update would not open. I had been using 6.3.6 for some time and since it did not show any additional addons beyond those that were part of Stacks, I didn’t know that is where I should have looked upon starting with RW 6.4. I think my RW 6.3.6 was corrupted in some way and that was the actual source of my problem. I just didn’t know how the addons should appear. So, thanks for the replies.