Stacks wont update, yet they will NOT!


(Jon Norris) #1

Sudden new RW problem. RW automatically updates - new version of stack installed. Screenshot 1&2. Yet it isn’t there. Not there in Finder either.

Quit RW (also shutdown iMac), reopen, same problem. Stack updates yet it isn’t there. Latest RW, High Sierra, etc. (Screenshot 3 shows old stack still). Each time I reopen, same stacks need updating.

Tried a New Project, added a new stack and it just hung with a button that did nothing - Force Quit only way out. (last screenshot)


46
01


(Andrew Tavernor) #2

Look in your Stacks folder (press cmd-alt-7 on a stacks page).

Have you got any duplicates of the stacks in question? i.e. have any of them got file names with a 2 after them?

If you have, for example, downloaded a stack and then downloaded it again with the original in your downloads folder then the new one will be called stackname 2.stack

This will obviously not update correctly as when the updater accesses the developers server, it will be looking for stackname.stack and not stackname 2.stack

As per your screenshot above, in yout stacks folder you should have a sinlgle version of ButtonPlus2 that will be called ButtonPlus2.stack

If you have ButtonPlus2 2.stack or ButtonPlus2 copy.stack then this will indeed fail to update correctly. The same applies for all your installed stacks.

This may not be your issue but it seems the most likely.


(Jon Norris) #3

No, checked that. No copies. RW says its updated but nothing appears in the Finder at all.
Even get a new error trying to add Stacks page to new project. (screenshot)

Was wondering if High Sierra and RW are not being friends.

01


(NeilUK) #4

No issues with High Sierra and RW for me at all, and I use RW pretty much all day, every day.


(Jon Norris) #5

OK, other errors too so have contacted RW.


(Isaiah Carew) #6

This looks a lot like a different issue I was tracking with another user. I’ll relay that info. I think the one big litmus test here – if you DO have a custom addons folder, give this solution a try – if your addons folder is in the normal location then this solution is not for you.

The symptom: random updates, addons not functioning, crashes.

The cause (short): The addons folder location became “unhooked” when the user upgraded macOS

The solution:

  1. Set the addons folder back to the default location.

  2. Quit RapidWeaver

  3. Launch RapidWeaver

  4. Set the addons folder to the custom location.

  5. Quit RapidWeaver

  6. Launch RapidWeaver

  7. For extra credit: Clear out the contents of the default location’s addons folder

The cause (long version): The user had a custom location set for the addons folder. (which is A-OK) But during some event (macOS upgrade? is my guess) the custom location for the addons folder became “unhooked”.

RapidWeaver still reported in the preferences that the custom location was correctly set – and sometimes would work that way – but at other times (most times?) it would fall back to the default addons folder.

The user’s default addons folder of course had old versions of plugins and stacks – this caused RapidWeaver and Stacks to attempt updates – which would fail.

Often random crashes were observed – I assume that various versions of various plugins were being loaded – so NEW version of RW would try to use a very OLD version of Stacks (and similarly with the Stacks plugin and 3rd party stacks).

The solution was to force RW to drop the old (and busted) custom location. To be safe, shut down RW to make sure this location is saved to the preferences file. Restart RW and verify the change. Then set the addons folder to a custom location again.

To be sure that this situation does not occur again – you can clear out the contents of your old addons folder. If RW does become confused again and starts to use the default addons folder mistakenly again, it won’t have all those old versions of things in there. That way RW will just load without plugins and hopefully tip you off that something has gone sideways and needs your help.


(Isaiah Carew) #7

If the above solution didn’t help – or you don’t even have a custom location for your addons folder – then I’d recommend trying a few basic tests to see if we can get back to something that reliable – and work from there to determine the cause of the error. It’s always easier to start at a working place and add complications until things break – than vice versa.

  1. Start by removing ALL your addons. Yep, every single one.
  2. Restart RapidWeaver and create a brand new file.

This should, in theory, work very well. This is plain vanilla RW. You should be able to create a new file, add pages to the file, save and preview without any errors or any problems.

Verify this assumption. Give it a 15 second play to make sure. Also triple check that Stacks isn’t loading and there are no themes installed.

If your plugins/themes are still loading – then the addons folder you cleared out is not the one that RW is using. Use RW to open the addons folder (Cmd-Opt-7) and clear that one out too.

If after clearing out all the addons things still seem broken in some way – contact RealmacSoftware. Those cases are very rare and probably outside of what forum folks can help with. They’ll need to collect more detailed info about your system.

Assuming things work with the vanilla install…
Download Stacks from scratch from the YourHead website: http://yourhead.com
Install it into your addons folder by hand (unzip it first, then just drag it into the folder).
Restart RapidWeaver.

Now you should have RapidWeaver with Stacks.
Don’t try to open your files yet (they probably need all the 3rd party stacks anyway)
Does this work? Can you save, preview add a few stacks?

If this is broken, then please contact YourHead Support. Like above this situation is rare and Christi will collect some info about your system and we’ll go from there.

Assuming this does work, add your Stacks back in. Does this break things? If so we probably need to go through the effort of finding the culprit stack.

If this works, then add back your other plugins (only the ones that you actually use – please leave out any addons that you don’t need – they all add complication and increase the chance of bugs and errors).

If this breaks things, then add them in one at a time until you’ve found the culprit. Hopefully there aren’t too many plugins.

Let me know where in the process the problems come back – and we’ll work from there to see if we can find a solution.


(Jon Norris) #8

Sadly, I wasn’t even aware you could have a different folder for add ons. In Preferences mine says “Managed by Rapidweaver”.

It is difficult in some cases to identify what version a stack is. You just have to assume the update has “taken” (which mine hadn’t)
The authors also use different tags when a newer version is updated (and is part of a set of stacks.

Can we add tags? I know we can group them…

PS Now to tackle your second answer - thanks…


(Isaiah Carew) #9

If the problem is larger (lots of random updates) then follow my guides above.

But your recent message makes it sound a bit more like the issue is just with the stack you took a screenshot above (the SQL stacks from Kuler).

If that’s the case, then just give that update another try. I worked with Gary this morning to correct a typo in his update “appcast” which was preventing it from working correctly.

I’ve tested it since and (at least for that one update) it works fine now.