Symbols converting text sizes

I regularly write technical bulletins and often they contain µm for microns. I write it in Word, then send out the pdf, but also add it to my site by copying and pasting plain text into RW.
This has worked for 12 years. Now, since some update, any text after the µm changes size to a miniature.

My work around is to eliminate all of these in the Word doc, then copy/paste, then add them back to both documents. But it should not be that hard.

Is there anything I can do to eliminate this RW behavior?

Here is one example bulletin. Boletín 214 | Widman International SRL

What are you pasting this into in RW, a stack, a RE page type?

Also, an update on Word might also contribute to this.

In general text formatting can be a bit of a nightmare. Usually pasting directly from Word is a bad idea, pasting as text with formatting removed (can’t remember the shortcut of the top of my head) provides better results.

The character codes for symbols such as mu for micro are often different between Word and html. Maybe best to paste as unformatted text and see the result, then find and replace with the html code for mu such as µ or see other options here Micro Sign HTML Symbol, Character and Entity Codes

to paste without format, I use option/command/V, so no format comes over from word. I can past into text and then copy and paste into RW, but get the same results, so it is an RW thing, or a Stacks thing with the text or right-floating text part of the basic stacks page.
I do not use formatting codes. That is why I bought RW.

Unfortunately I no longer have a working version of Word on my mac to test with. From Apple Pages and your own site the mu symbol copies into RW (8.9.3 on High Sierra) fine and previews ok on an html stack.

When you say miniature is it converted to subscript?

I did not try to figure out if it was just small or subscript. Just as I type µm here as “u” “m” the computer changes it to µm

Then it is RW that gets confused.

Currently running Big Sur 11.6. MS Word is 16.52, but as I said, that is irrelevant, as I’m pasting non-formatted text.

menu> edit>pastes as plain text opt+comand+ v should work. I believe this is a standard Mac process that RapidWeaver uses.
I’m not at a Mac right now, so I can’t test it out until tomorrow (I have Word) but never use any of the dictatorial or special characters.

Have you tried copying and pasting as plain text into another application?

Copy/paste works without problems into mail, messages, WhatsApp.

I just tested this:
Using M/S Word for Mac (16.54), Big Sur (11.6 (20G165)).

  1. Opened a word document
  2. Added The following text to the page
µM µm
  1. Selected the text and copied it to the clipboard
  2. Added a markdown stack to a page in RapidWeaver (Version 8.9.3 (20888))
  3. Opened The Markdown Stack in RapidWeaver and removed the default content
  4. Pasted the clipboard content (µM µm) as Plain Text (⌥Opt+⌘ Cmd+V)

And it works fine:

So maybe an issue with your install of RW or stacks?

Have you tried reinstalling RW and or stacks?

What is a markdown stack? Does it go into a regular text stack or act like one? Can it go into or become a right-floating image stack?

A markdown stack used markdown syntax. It’s easy to pick up and produces much better structured HTML output. It comes with stacks just like the text stack.

I also tried the same test with a text stack. It works perfectly, just like the Markdown stack.
I’m pretty sure that the paste as plain text function is a standard xcode (the development platform that they developed most Mac apps with) function.

So mine still does not work properly in text stacks. I thought for a moment maybe it was because I normally use Spanish, but I just tried it in English, and same results.

Not sure what might cause the issue for you.

One thing I noticed, you say “copy/paste” works without problems in mail, messages.
Apple Mail app and the message app built-in to the Mac, doesn’t have the Paste as Plain Text option.

They both do offer Paste and Match Style. So when you say you tested these, and they worked, How did you test pasting them without the Plain Text (⌥Opt+⌘ Cmd+V) option being available?
Paste and Match style appear to be the only common paste options.

Messages App:


Mail App:

RapidWeaver App:


I don’t have WhatsApp so I couldn’t look at the edit menu for that.

Are you running any utilities like a clipboard manager or keyboard utiltity?

When option/command/v does not work, I use command/v. A macro lets me run the same combination in Excel since they did away with the paste values icon around 2016.

No other utilities

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.