The mystery of the Contents.plist file permissions

Been trying to publish a new website and I keep getting the attached.

Tried searching for the file withous success. Tried Google without success.

Anyone any idea where this file is and how to stop this happening?


Is the publishing at the end successful? Or doesn’t it even start, and you get this error?

Open the file package of your project (control click) and check the permissions of the content.plist

I think it publishes OK then I get the message. The permissions are OK.Screenshot 2021-06-05 at 11.51.33

Thinking on I cannot find it on my server so perhaps it did not publish.

Are all other files published? This file is part of the RW project file and will never be published.

Did you enable the backup of the project file on the server?

Sorry but I have no idea whjat you are talking about. All my other websites update OK with Rapidweaver just this new one one fails. I am not a Computer expert - this is why I use Rapidwever and have done for years without a problem. This is now becoming annoying.

Therefore I want to help you. Sorry if that’s not wanted. Cheers.

You posted about your problem less than two hours prior to saying that you are annoyed with people on their own time, asking questions trying to help you.

You’ll find that most of the users here will be much more likely to continue trying to help you fix your problem if you drop all the frustration and answer questions they are asking nicely.

The question was about backups on the server, in publishing settings in Rapidweaver, there’s an option to back up your project file to the webserver. Do you have that option turned on?

Do you have any other backups running on your Mac like TimeMachine or Backblaze?

1 Like

Firstly let me apologise, I was not getting annoyed with anyone here trying to help just annoyed that I am being asked questions that I have no idea about. Please do not assume that everyone is as knowledgable about this is you are.

Secondly I have found out that my isp does backup and Time machine does as well but this is a new website I have created and no backup yet plus there is nothing to backup yet as for some reason it is not being posted.

If there is an option for Rapidweaver itself to backup I do not know how to do this so asking me if it has been done does not help.

You can see I am frustrated mainly by people like you assuming too much. If you have no idea why I am getting this message about contents.plist just say so and stop trying to be clever.

@instacks is referring to backing up the RW project file to your server which you can get RW to do by setting the backup frequency in the publishing settings.

1 Like


Please, I am not asking about backups but why the contents.plist file is not accessing.

Because when creating this backup, the actual RW project file is zipped and uploaded to the server.

If the content plist, which is part of the RW project file, isn’t accessible at this point in time, it might come to your symptom.

Clever, hmm?

Obviously this seems not having happened to anyone before.

Sorted it out myself now thanks.

You might want to try and restore an earlier version of the RW project file from TimeMachine.

As mentioned by Jannis @instacks, the plist is part of the project file. The message is probably telling us that the project file has become corrupted.

That’s why people are asking about backups.

Since you have never published it before then you don’t have a backup on the server.

I said this ages ago.

@bluecob You might want to help someone else if they run into this same problem in the future. So when you say “sorted it out” exactly what did you do?

This is an extremely rare situation … so you’d be helping another person in a similar situation in the future if you provided details.



I would help if I could but no idea what I did other than try another location for posting which seemed to work.

Hope that helps.

Is this file on Dropbox or some other file sync service? I find the file name suspect. I’m pretty sure that it should be Contents.plist and not ._Contents.plist