Total CMS blog and big images


(Bjørn Arve Iversen) #1

Hi everyone
I have used the beautiful Total CMS blog. It works fine :-), but I have one problem. When I add photos (jpg) to the blog, the photos are saved. But when I look at the actual blog some of the photos are missing, And if I go back to the admin page these photos are shown as an empty square with a cross over. It seems to be big photos (2 Mb +) that have this problem.

I thought the jpg files was automatically downsized (from one of Joe Workmans videos about Total CMS images). It seems like I was wrong. Is it possible to make Total CMS Blog accept bigger images? I have triad to change every size related setting I have found — except for the correct one.

Have nice days everyone
Bjørn Arve


(Joe Workman) #2

If you look at the Total CMS debug output, you will see if your server has all of the proper libraries installed in order to resize images.

Next, it’s also possible that your server does not have enough available resources to dynamically resize images. Does it work if you upload a smaller image?


(Paul Russam) #3

I’ve run into the server resource problem Joe mentioned with my previous host. They had very restrictive upload rules and if too much time/processing power was being used the server would abort the process.
Easiest way to test is to copy a bunch of the images giving you problems, reduce them to a sensible size (lets say 3000px across) and try uploading them.


(Jason Bostick) #4

I had an issue a while back with a host that set a default upload limit of 2MB’s, if I remember correctly. It was an easy enough fix once I requested a change. To do it yourself, I believe there is a php ini file that you can edit (the location and method to access it might vary by host)


(Bjørn Arve Iversen) #5

Hi
There was a limit set on the server (2Mb). I have now increased this limit (4Mb). Now the import works well, but I still get an error message in cms.log.

Mon, 19 Nov 2018 10:01:59 +0000 (88.88.16.235) : ERROR:PHP ERROR [8192] Function create_function() is deprecated (/home/X/xnbslkkaiua8morg/www/rw_common/plugins/stacks/total-cms/vendor/michelf/php-markdown/Michelf/Markdown.php line:1873)

I have also used the CMS Debugger (Server check).

CMS Debug Info

PHP version: 7.2.9
HTTP_HOST: www.båsløkka.org
SERVER_NAME: www.båsløkka.org
DOCUMENT_ROOT: /home/X/xnbslkkaiua8morg/www
DOCUMENT_ROOT (realpath): /home/X/xnbslkkaiua8morg/www
SITE ROOT: /home/X/xnbslkkaiua8morg/www
POST_MAX_SIZE: 8M
UPLOAD_MAX_FILESIZE: 4M
MEMORY LIMIT: 128M
MAX_EXECUTION_TIME: 30
CMS VERSION: Total CMS v1.4.20 (7584)
Total CMS Passport Check: {“status”:true,“info”:“Domain registered”,“trial”:false}

I have also tried to find a description of which PHP-extensions I shall activate. Have not found it.

But it works now, despite the error messages.

Best regards
Bjørn Arve


(Bjørn Arve Iversen) #6

Hi thanks for your answer.

I have done exactly that — reducing the size before import — that works for me. But I can not ask my customers to do that,

But you gave me an idea. I see that MAX_EXECUTION_TIME on server is set to 30. May be I can increas that value. I will give it a try.

Thanks a lot.

Bjørn Arve


(Bjørn Arve Iversen) #7

Hi and thanks
The limit was set to 2Mb. I have increased the limit and now the images are imported just fine — even if I still get an error message in the cms.log file. I guess this indicate that the automatic compression do not work. Not shure.

But it is working.

Thanks a lot.

Bjørn Arve