Tracking & displaying no. linked file downloads


(Alex) #1

Hello; hoping someone can help me.
I’m building a site for a free eBook PDF that requires the number of times the download link is clicked to be visible on the site so the authors know how many people are using their resource.
I’ve bought Doobox’s True Download 2 stack (https://www.doobox.co.uk/stacks_store/demos/truedownload.html ) but it gives an error message every time its used (see pic).


The website is here if you’re interested:
https://rrthandbook.org

I’ve contacted Doobox support a couple of times with no response (yet) & the site is being advertised from October 1st.

  1. Does anyone know what the error message means & how to fix it?
  2. If this can’t be fixed, is there another way I could track file downloads & have them displayed on the website (rather than in a text file on the server that only I can access)?

Many thanks
Alex


(scott williams) #2

First, check your hosting and make sure curl is enabeled


(Alex) #3

Thank you. I don’t know what that means but will now email them to ask.


(scott williams) #4

cURL is a library that lets you make HTTP requests in PHP make sure it is enabled in your cpanel or ask your host to enable it for you.


(Alex) #5

Thanks for clarifying. I’ve emailed support.


(Alex) #6

cURL is enabled (see http://wellingtonicu.com/curl.php)
Does @doobox have any ideas?


(Doobox Software) #7

Hi Alex, @alexps

Firstly, I did receive your emails, and also replied. Please check your trash / junk mail.

Thank’s to your very detailed description of the issue you were seeing, along with exacting console logs, I believe we were able to identify and fix this long standing bug that affected a few users.

We could never replicate this bug here, and still can’t, so it’s server specific, but was absolutely a bug in our code. As were still can’t replicate the bug here, we can’t be 100% sure we have fixed it, so we sent you an updated version some time ago to test in a known environment that produces the bug (your page).

So if you can let us have an alternate email address or dropbox link we’ll send it over again for you.
You can continue to contact us at support@ as we’re getting your email just fine, your just not getting our replies at the address you used previously.

EDIT: I have given you a download link to test in the PM you sent me here on the forum.


(Joe Martin) #8

You have to make a .zip file from the .pdf file…then it will work great…I use it all the time.


(Doobox Software) #9

Thank’s Joe, that’s a common issue people have, not reading the FAQ on the demo page. In fact people using a PDF directly tops our support list. But that is not the case here, When checking their page originally, that was the first thing I looked at, the are using a zip :slight_smile:


(Joe Martin) #10

I just ran it with the counter showing…and got the same error…can you see the error…if not…look at this page…
http://www.ibize.com/timberline/Plans/#


(Doobox Software) #11

@joemart1951 If you can contact us at support@ we’ll hook you up with the updated file to test as well as grab some more info.


(Alex) #12

Sorry Gary, didn’t receive anything in spam/trash/junk (I always check before recontacting anyone). I did get automated emails from support telling me you’d be in touch soon though. Weird. Apologies for harassing you & many thanks for getting back to me.

However, much more importantly, thank you very much for the new version of the stack (from the DM). It has completely fixed the problem! All buttons now work as intended.
Cheers
Alex


(Alex) #13

Can confirm, had read FAQ & already zipped all the files.
I promise you I’m not that person who immediately contacts support before I’ve tried a google search, the webpage of the manufacturer, the manual of the stack, any FAQ in existence and then the forums here. I even googled the exact error message to see if this was a common mistake!
Thanks to @Doobox its all fixed now.
:grinning:


(Joe Martin) #14

Ok…after some fiddling with it…and clearing some stuff up…all working great…thanks for your help.


(Doobox Software) #15

Great, thanks for testing guys.
I will issue a public update to the stack shortly.


(system) #16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.