Trouble with Magellan Links in TopBar


(Peter Rood) #1

Hi Everyone

I am having trouble getting my TopBar links to actually do anything. They look great, but don’t move the site to my Magellan Markers. Maybe I am doing it wrong.

Here is what I did…

I added TopBar to my Foundation Site. Selected the Magellan Menu option.

I added Magellan Markers to select areas on my 1 page website. I gave each marker a simple yet unique ID.

Went back to my TopBar and updated the default sample code with the proper marker names.

Nothing happens.

I put in a support request, but I don’t think I will hear back until some time tomorrow. If anyone could let me know if I am doing this right I would be grateful.

Thanks.


Help with adding more links to TopBar (using Magellan nav)
(Robert Ziebol 🖖🏼) #2

My first bet is you do not have Smart Quotes turned off. Check your quotes on the html set up for Magellan links in TopBar.


(Peter Rood) #3

I don’t see any “Smart Quotes” setting anywhere. Are they part of TopBar settings?


(Robert Ziebol 🖖🏼) #4

(Peter Rood) #5

Ok, I did that, re-applied magellan markers and nothing works. I also never changed the sample code for TopBar… I only changed the ID’s


(Robert Ziebol 🖖🏼) #6

Can you paste your code in here? Use this button </> and then past the code between the two spots.


(Peter Rood) #7

@zeebe You were right. I went back in and checked my quotes in the code and it had curly quotes. I have it working now. That is pretty strange, but I am glad I am good to go.

THANKS!