True Download not working


(Henry Halem) #1

I’m using True Download from doobox. I have set the URL correctly I believe. The download works fine in Chrome but does not work in Safari, or Firefox. I cannot figure out what the problem is. The link for the download can be found at henryhalem.com scroll to the bottom of the page and you will see the True Download button. Can anyone help?


(Dave Farrants) #2

Quote from True download page:

What are the downloadable file types?
The short answer.

Put the files you want to download inside a ZIP file, and point the True Download button at that ZIP file.

The easiest solution is to put your file (example: a PDF file, a movie file) inside a zip file if possible (If you are using the PDF Stamper plugin then you can’t do this unfortunately). Browsers cannot read zip file so it will force a download. Most computer users know to unzip the file and get the content from inside.

Your link points to a pdf.

For PDF’s, I use an embed stack, put the file on Google Drive, select make public then put the link in the embed stack.

I’ve also used S4S Paperless stack for some PDF downloads, works well.


(Henry Halem) #3

I’ve zipped the pdf and uploaded it to my server. Do I’ve put the zip into my resources and created the link. I now get nofile in all my browsers. I could make it easy and just create a download which I know will work but I wanted to use this stack to keep an eye on the number of downloads.


(Doobox Software) #4

Try changing the link form
resources/Halem_Resume.pdf.zip
to
https://www.henryhalem.com/resources/Halem_Resume.pdf.zip

It’s also in the FAQ that the stack requires an absolute URL to the file.
Using RWs built-in links panel option to link to a resource file produces a relative URL.


(Henry Halem) #5

Bingo! I just changed all my sites to https and did not notice that the link was still http. Thanks for the sharp eyes @Doobox and thanks @DaveFox for your help.


(Henry Halem) #6

Interesting though, Firefox no longer opens the site now that it’s https. It tells me that it is not secure. How do I get Firefox to recognize the site and the other sites I’ve converted to https?


(Doobox Software) #7

Have you cleared the cache in Firefox?
or are you still accessing the site in Firefox using an old http bookmark perhaps?


(Henry Halem) #8

It tells me the https is an insecure connection.


(Henry Halem) #9

I’ve cleared everything I believe.


(Doobox Software) #10

Looks fine here in Firefox, so somethings cached somewhere.


(Henry Halem) #11

@Doobox when all else fails, hit restart! Like my friend said if the do not resuscitate buzzer goes off try hitting restart.


(Bruce Kieffer) #12

Read this. It may help:


(system) #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.