Unable to export site


(Mike) #1

Rapid Weaver - version 6.38
Foundation - version1.70
Add-on Packs 1 & 2 - version 1.76

Since the last update, I am no longer able to export an HTML site in order to preview it. I get a message - “Please enter your Website Address. RapidWeaver needs to know your website address, so that links between pages can be correctly generated”. Whereas there was an option to browse to an Export Folder

I have tried creating a new test site, and get exactly the same result.
Also on the site I’m trying to preview, the extension under General Settings has changed to PHP, yet under Tools > Advanced, the extension shows as HTML. I have as far as i know not added any stacks that require PHP.

Any assistance would be appreciated.

Thank you,

Mike


(Brad Halstead) #2

@mike_hamilton

This indicates to me that you have not defined a website address for the project in Configure (Project Settings) -> General -> Web Address

To my knowledge, RapidWeaver 6 will not change page extensions from the default unless something on the page requires it, so what exactly is on the new project page stack wise?

Brad


(Mike) #3

Hi Brad,

Thank you for the quick reply.
I had added the web address previously, but deleted it and then re-entered it.
I have re-created the site from a blank project and copied and pasted all the relevant stacks into their correct places.

Now when I try to export and preview the site, I get the following message - “Unable to launch external preview - Due to a change in OS X, it’s not possible to preview pages with a PHP extension in an external browser. Please either launch your site while running a web server on your Mac (MAMP is a popular option), or upload your project to your hosting provider to view it.”

I have no idea what’s going on, because I uploaded the site a few days ago into a test area and all went well, I have done no other work on the site until this morning when I came to make the site “live” for my client.

I have just uploaded this newly created site and it does work. Checking with FileZilla, index.html has been renamed as index.php.

The site can be viewed here

Any ideas?

Thanks,

Mike


(Brad Halstead) #4

@mike_hamilton

Hi Mike

The FORM on the page requires PHP…

This is correct, PHP pages cannot be previewed locally in browser, they need a server that supports PHP such as MAMP or a live dev area on your host (in RapidWeaver 5 & 6)

Some things to watch out for:

  1. Some links that you have may be bad due to changing of paths from dev site to live site (test every page and every link)
  2. If there are PHP and HTML pages at the root of each folder, double-check in RapidWeaver Project for the filename
    extension, delete the bad one from the server.

You’re using a single page site so there should be not issues, page links seem to work ok to the various sections…

Does that help?
Brad


(Mike) #5

I’ve not added anything relating to php. All this started when I upgraded Foundation a couple of days ago. The test site worked absolutely fine - the page was HTML, I was able to export and view the file. No for whatever reason, the index page has given itself the extension .php. It won’t allow me to change it to html and neither am I able to change the extension to HTML.


(Brad Halstead) #6

@mike_hamilton

The Foundation Form elements require PHP… that’s why it changed, perhaps there was an update that forced this on Joe’s side, I am not sure to be honest, but the form definitely needs php to send… @zeebe do you have anything to add?

Brad


(Robert Ziebol 🖖🏼) #7

Actually, the form elements only need php on your server, you do not need to have the filename set to php. The ONLY thing in Foundation which will change your filename from .hmtl to .php is SEO Helper. If you added that to your page, then that would do it. There are many non-foundation stacks that will do this as well though.


(Brad Halstead) #8

Thanks @zeebe for the input

Brad


(Mike) #9

Hi Zeebee, SEO Helper wasn’t added.
What I cant understand is why it all changed without any input from me, apart form installing the Foundation updates the other day.
I don’t use PHP for the contact form, the email the user (viewer) sends goes directly too the end-user. It’s the same form as I’ve used on a few other sites without issue, all I do is change the forwarding email address.


(Robert Ziebol 🖖🏼) #10

Not sure what to tell you but the foundation update that went out would NOT change your filename from html to php so something else must have happened. Your server still NEEDS to have PHP on it to use the Form stacks.


(Mike) #11

Hi Zeebe,

Server has php installed on it, though I am totally at a loss that why the test site uploaded to a test folder on the server 2 weeks ago has saved as an html file and yet the site to be uploaded onto the server to make it live, without anything whatsoever being done to it (a duplicate of the test site), apart from the Foundation updates applied has essentially screwed the site up. No other updates have been installed for the past two or three weeks or so.


(Robert Ziebol 🖖🏼) #12

Send in a ticket to support(at)joeworkman(dot)net and included your zipped project file. If the file is over 1MB in size, you will need to use a way to host the file like Dropbox. This way I can take a look at it.


(Mike) #13

Hi Zeebe,

I’ve been out of there country, but have just sent you the file in Drop Box. Let me know if you get it (or not).

Cheers,

Mike