Updating to 8.1 and now my site is gone. very unhappy!

I had been using the 8.03? version of RW and updated my site. It took me forever to figure out how to upload the site using SSH keys to my server. Finally got that done and went to update the site but I was asked if I would like to update to 8.1 and I did. Went to open the site and no pages show and I was asked to give permission for RW to access directories where my photos were stored. I have tried everything and I got nothing. The file where my site was stored opens up to the FTP settings page that I updated with the SSH keys but shows none of my website pages. I am pretty displeased right now. Boy I wish I could take back that action to update to 8.1

Have you read through the other threads?

Yes I have looked at them, but nothing I have tried has brought my website back to life. I may try using the file from time machine before I updated to 8.1

Just curious. How is your situation different from other users. What images are on your machine that the project is referencing?

I am just trying to understand how you are adding images differently to a project from me. I have been using RW8.1 for months and have not had this issue.

FWIW, and I hope this is helpful for you, here is a message I received from Dan at RealMac this morning when I was having some problems with the 8.1 update and opening files in 8.03.

From Dan Counsell:
If you recently published with 8.0.3 (and have the backup option on) you may have the project file backed up on your server…

Don’t know how I did things that differently from you Joe. My website is pretty photo intensive, as it serves as a portfolio for my artwork. I had all of the photo stored on my MacBook in a folder in the Pictures folder that all Macs have. I also store all of my photography files using Lightroom in this folder. I tried pointing 8.1 to the folder with the files, with no go. I then tried pointing it to every subfolder within the main folder for my RW pics and still no go. I couldn’t see a single page of my website. I just realized I could open a 8.03 file from time machine and got my website back (I had almost immediately reinstalled 8.03 but not before I had saved the site in 8.1) With 8.03 and my time machine backup, I am back where I was. I certainly won’t upgrade to 8.1 till I know there is some sort of fix for this. Way too stressful.


Michael Foster



Are you using the built in photo gallery page? A stacks page? How are you adding these images into the site?

Can only agree Rapidweaver has completely messed up my site. Asking for files in different locations. Then not showing lots of images from previous months. Absolute crap and ballocks.
Had already got the problem of pictures not showing in edit mode when one adds them. Incandescent. Ten years work down the drain.

Yes, if its true that projects updated to 8.1 can no linger be opened in the last known working version of 8.x.x and 8.1 didn’t come with some great big huge warming signs, or better still a duplication process as per 7 to 8, yes, that is unforgivable.

But, if in ten years you’ve never backed up your work, that’s on you.

Absolute bollocks again. Focus on the unforgivable not my shortcomings. The fanfare that accompanied 8.1 was rather loud. As it happens I do back up my work and I’m not particularly tech savvy. You buy a programme like this and largely expect it to work without these major frustrations.
I found the last backed up copy of my site and downloaded 8.03 and thought great only a few entries to redo. Nothing happens. I can’t redo those entries because nothing happens. The wretched programme won’t allow me to add the extra entries.

So to repeat a worn phrase Bollocks

Sorry that was a word.

What do you mean with that exactly?

Tried to add images for a new entry. It looked like the pictures were going to drop in as usual, the little rainbow bar spun for a moment but then the pictures were thrown back to my hard drive.

rainbow ball not bar

I guess we are not able to follow up correctly. What d you mean with new entry?

Don’t misunderstand, just trying to help here.

Very much open to help. Just not happy with condemnation. Will do my best to describe as asked.

Using the blog page. Have clicked on the + to add a new page/entry. All set to add a picture and that’s where it won’t accept it. I usually just drag and drop them, have done for years with no problems. But no way. Does as described previously. Does accept text though.

Even when using this old version 8.03 and I create a new site this still happens. Blog entries will accept text but not pictures.

Hardly a condemnation. I just pointed out the obvious: Yes, you can blame RW for the cluskerfuck that is 8.1, but you’ve only yourself to blame for not having daily backups. It’s not like Macs don’t have a backup system baked right in!

Backing up your work on a computer is not being tech savvy, it’s using common sense.

You are clearly not worth the bother.