Upgraded from version 4 to 6 after upgrade to Yosemite, my content is missing


(kaz) #1

RapidWeaver Version: 6.3.4
System Version:10.10.5
Hardware: 27in iMac 2.7 GHz Intel Core i5

Have upgraded from version 4 as I upgraded to Yosemite from Lion and purchased update for rapid weaver as version 4 would not load in Yosemite. The site has imported into version 6 but in the styled text pages all the content is missing?? I have pages with a lot of links in have I lost them all will have to type all my a to z pages again?

I notice blocks pages are all ok!

Many thanks


(Oscar Schmid) #2

@jpl5000
Open and save first your project with RW 5.4.1
Then you can importe with RW 6
Otherwise you loose content.

You can get RW 5.4.1 here.


(Victor Briseno) #3

I can’t even open RW 5.4.1 So I have no way of upgrading to RW 6 without losing my contents and plugins


(Oscar Schmid) #4

@sanacionestelar
And your plugins are up to date? Have you installed PlusKit?
Look here and read this http://realmacsoftware.com/rapidweaver/upgrade/


(Victor Briseno) #5

I can’t open it in order to know which plugins I have installed in order to be able to upgrade them. As it simply stopped working I have no access whatsoever. I already tried installing the 4.5.1 version but it freezes at startup too.


(Oscar Schmid) #6

@sanacionestelar
You’ve worked with RW 4, not with RW 5?
RW 5.4.1 you only use for upgrading to RW 6?
If so, save your project with RW 4, check the plugins (perhaps delete PlusKit when not used in this project), then try again to open it with RW 5.4.1.

Do you have repaired your rights, using Disk Utility?
You work with Yosemite or El Capitan?


(Karn Broad) #7

Your issue is plugin related - RapidWeaver 4 DOES run in Yosemite. Somewhere you have a really old plugin file in it’s support folders - this will then crash RapidWeaver 5 too.

In Finder, look in the Go menu and choose Go To Folder.

Paste this in the dialogue

~/Library/Application Support/RapidWeaver/

and it should take you right to the RapidWeaver 4/5 support folder. Remove any .rwplugin files in there you can do without and reboot so you can try again.

With best regards,
Karn.


(Victor Briseno) #8

I can’t open RW 4 nor RW 5 thus being unable to save for import to RW 6


(Oscar Schmid) #9

@sanacionestelar
I cannot understand, why you can’t open RW 5.4.1.
You must have a problem with your computer.

Or try this. Move your plugins (use Karn’s link) in a different folder (on the Desktop), then try to start RW 5.4.1. This as a test. Later, you put this back, maybe a plugin after another.


(Victor Briseno) #10

I managed to open RW 5.4.1 with these instructions but It asks me for a licence, I only have the RW 4 licence and the RW 6 upgrade licence. I only want to open RW 5 to save my webpages and then migrate to RW 6. What should I do now?


(Oscar Schmid) #11

@sanacionestelar
For RW 5.4.1 (not 5.4 !) you don’t need a license.
I hope @nikf from Realmac read this thread.
I don’t know, what else you can do, unfortunately.


(Nik Fletcher) #12

Your license from our store should also include a license for RW5 - however there’s no license required to open and save your project. You should choose to run the demo, and then open and save the project.

—Nik


(Oscar Schmid) #13

If you can now open RW, certainly an outdated plugin is your problem.
Show us a screenshot of your plugins. Then we can have a look.