URL links not responding to settings


(David Bailin) #1

I published a page called Studio Documents. Within that page is a series of links under Reviews and Criticism that should open within the same window/tab. However, when arriving at the page, the initial selection of those links are marked to open in another tab. What is really weird is that the link to go back to the Studio_Documents page will open as it should in the same tab and, even more bizarre, all the links on that page will open correctly too. So landing on this page will open any link in another tab. Once in that new tab, the link to go back to the landing page will open correctly within the tab and ALL links on that page will also open correctly. Anyone have any idea why this is happening?

See my page: https://www.bailinstudio.com/STUDIO_DOCUMENTS/ and follow the links in the Reviews section. Thank you for your suggestions.


(Isaiah Carew) #2

My guess is that there’s some stack that is changing the click target of something – but has gotten a little overzealous and is changing a few too many things on the page. When you find which stack is responsible, perhaps you can adjust the settings to disable this bad side effect, or report the problem to the developer.

But there are a dozen so complex stacks on that page and about that many javascripts running as well. I think unless someone knows of some specific bug, then it will be difficult to find the needle in that haystack.

I’d probably recommend making a test page – a copy of that page. Try eliminating the various other stacks on the page util the problem goes away. When the problem disappears you probably have your culprit.

Once you know the stack in question, we can help you more directly in finding out why its misbehaving.

Isaiah


(David Bailin) #3

This did not occur until the RW8 update. While I did look at the pre-updated version of the page and find nothing different about its setup, I will reconstruct the page from scratch to remove any left over stacks or scripts that may be causing the problem. I’ll get back to the forum with the results. Thanks for the suggestions.


(Isaiah Carew) #4

I think what I suggested would only take a moment – rather than recreating everything again – which would undoubtably take much much longer.

And by doing what I suggested, you’re likely to learn which part of the page is failing – and be able to fix/avoid that bit in the future.
Recreating the page from scratch might solve the problem – or might recreate it – who can say. But it definitely won’t get you any closer to understanding the problem or learning how to prevent it.

But, whatever, my suggestion was just that – if you want to go your own route, that’s cool too :smiley: I’ll move on to other folks. Good luck.

Isaiah


(Joe Workman) #5

When I look at the source code, you have target="self" set on all links. The actual syntax if you want to put a target inside of your link is target="_self". If you really want a link to open in the same window, it’s easier to simply omit the target attribute all together.


(David Bailin) #6

I noticed that. I must have thought that would help but as I know no code I screwed it up. However, I noticed in the address bar that when you arrive at the Documents page from a search or bookmark in Firefox, there is no lock icon next to it. If you go to any link within the Review toggle the address shows the lock (https). Is there a problem, not with the page, but how the website initially loads that is corrected when you leave that initial page?


(Joe Workman) #7

https seems to working on the site for me in Firefox.

So the target attribute fixed the link issue?


(David Bailin) #8

That didn’t work. The problem lies in the TOGGLEPLUS stack and how the page loads initially. I have placed the issue in a new window and put the Documents page back to its original state.

Here is the link to the error page with the Reviews section copied outside of the TOGGLEPLUS stack
Https://www.bailinstudio.com/PROBLEM/


(Joe Workman) #9

The HTML source code contains that target attribute. This means that it is not Toggle Plus. I am not sure why its only opening inside of a new tab when in Toggle Plus. The real solution here is to fix those links and remove the target attribute.


(David Bailin) #10

The solution: I had all the links to the reviewer pages listed within the same text stack. I placed two of the review links in their own text stacks and that seemed to work. All the rest of the links in the text box worked correctly and opened in the window. I don’t know why that worked. But I’m pleased.

I appreciate all Joe’s and Isaiah’s help. I also contact Will Woodgate who assisted. This is a responsive and helpful forum. Thanks all.


(David Bailin) #11

Solved the Studio_Documents page issue BUT now when I select the return link: https://www.bailinstudio.com/STUDIO_DOCUMENTS/#REVIEWS it opens in a new tab. I just moved the problem to another webpage. What’s happening? Doesn’t this sound like a RW8 links set up problem?