Video Wall, Youtube not working whatsoever

Is this working for anyone? is there a guide to using the new additional API stuff in the stack?

You need to generate an API key and you need to populate the “project ID” field with anything, just needs to be something in there.

done and done, doesnt work

if i make a completely blank project with nothing but a stacks 4 stack page and video wall i cannot make anything appear…should not the default even work?

here’s my url, love to know what is going on, this stack seems to have gone from easy to use to a nightmare

Do you have a url to look at? And maybe a screenshot of your settings in edit?

please do!

ps is there a guide re the credentials? i did this a year ago, i dont think its working now

can you post a screenshot of your settings in edit view?
Maybe try to enter a number in the project name field rather than text. Just guessing…this is the main difference I can see between your application and mine on

Yep nothing works, ive been able to link single youtube videos using other stacks so i know youtube is working, but nothing from the feed whatsoever, i just did another tutorial for the API credentials (Why isn’t there anything on the Video Wall support faq?!!) and generate a fresh key, still absolutely nothing.

Does Video Wall need to be on a PHP page? Yours is HTML.

The Video Wall stack page mentions PHP in the release notes.

trying to add a numeral in the project name on the google console…good grief, their stuff is all over the place

great question, doesnt seem to make a difference when i test it

If you change the page to .php instead of .html, you’ll need to republish the page and delete the HTML version from the server.

doing that just now, wanted to make sure my menu would still work, think it will since it selects pages instead of specific urls

Do yourself a favor and name every page index.html or index.php. I set my project default to be PHP for every new page. Saves some headaches in the future. With mixing up html and php pages.

1 Like

Thanks Joe, just republishing now…what a headache! (Anyone know how to add webmaster tools shortcut in google? they seem to have removed it…not v helpful)

Thanks Joe, just republishing now…what a headache! (Anyone know how to add webmaster tools shortcut in google? they seem to have removed it…not v helpful)

Still not working!

You seem to have a bunch of scripts (or additional stacks? Socialfeed?) on that page. Try deleting them. Might work then. At least there is some strange code at the bottom of the body tag.

thanks Markus, thing is, as i have said, a fresh stacks page with only the Video Wall stack and the settings renders nothing…ill make one and publish it.

annnnnnnnd still not working, this is the stack hosted in foundation 1.x and latest stacks…im about to give up and seek a refund unless someone has some useful insight, it really should not be this difficult - if im making a mistake this should reveal it. would appreciate if Joe could chime in

If one checks the element this is what you get: 500 internal server error.
I am not a coder but perhaps the more code savvy guys can step in here.

thanks, im close to working out what has gone wrong

  1. Youtube API NOT WORKING

Huge tip for everyone : Make sure you are using you main google identity, i was using my boxcar one…
exact same API setup, not working - create the same in main identity, worked immediately. Be nice if someone explained this stuff a bit clearer.

  1. Something changed in the stack and the # of queries from the channel videos had been reset to only one.

  2. The column setup somehow became screwed up

Nothing to do with the other stacks etc (used to work fine, only the recent Video Wall updates have stopped it) I am wondering aloud if this stack is being tested in Foundation 1.x because i havent made the time investment for foundation 6. As i say, used to work with all the settings i had previously published.

yep so fixed it myself, API was the main issue (dont use migrated youtube -> google accounts for credentials), but something in the stack updates also screwed up the Video Wall settings which worked fine before.