WebYep login problem

I have installed and configured the webyep-system for a final test. When I now click on the lock on the uploaded web page to log in, the message appears that I have to activate JavScript in the browser. But JavaScript is activated. And at the demo on the site from Stacks4Stacks (WebYep | Stacks4Stacks), the login with the same Mac works fine…
Where could the error be?

Mac OS 10.14.6
Safari 13.0.3
RW 8.4.1
Stacks 3.6.9
WebYep 2.3.0

Have another careful read of the product page again. Hint - the final paragraph.

1 Like

What worked for me was changing jquery to none in config-inc.php line 228 and 235, so:

$webyep_JsLibariesType = "none";
$webyep_sModalWindowType = "none";

No guarantee though it will work in your case…

omg, that’s embarrassing. And even under a really fat title. :roll_eyes:
Thanks Will!

It works, thanks Jeroen!

1 Like

I have a really bad start with WebYep.

The following problems:

  • I have a WebYep Image Gallery in a WebYep Grid Stack. When I activate dummy content, it looks like in picture 1
  • When I look at the pictures online, it fits like in picture 2, but when I close the lock for editing, the three pictures lie on top of each other like in picture 3.
  • To avoid possible problems, I omitted all unnecessary Foundry stacks. Now I can edit the content of a Rich Text Stack, but the content is not displayed. When I had the stack in an Accordion Item from Foundry, it worked.
  • I wrote Max a few days ago that I bought the license (as it says on the WebYep page) and that I don’t see the features of the Rich Text Editors in my example. But in your demo I did… So far I haven’t received an answer.

Possibly I make a fundamental mistake somewhere that these various problems occur. Maybe it doesn’t work properly with Foundry. I don’t know. But in the meantime I have spent many hours solving the problems, but unfortunately I can’t get any further.

Does anyone have any ideas?

Try dropping the exact WY gallery stack in a different theme to see if it is related to Foundry. I have almost no experience w/ Foundry, but quite some with WY. It’s hard to say without a URL, but from here it seems that the theme is overlaying the gallery images over one another.

1 Like

As a general rule of thumb, no link = no help


Redactor rich text editor controls only get shown if you own a license to Redactor, available from Max. Otherwise you will have to edit your config file to use one of the other two rich text editors interfaces. This is already covered in the documentation.

Like us all, Max sometimes goes on holiday. If you are in desperate need of having Redactor, get in contact for a temporary copy.

Same with the other issues relating to images. Screenshots tell us nothing at all about your setup. There are a million reasons why one image might overlap another image. At this stage, I’m speculating it is something external to WebYep. The web developer console would say exactly what.

I hear the developer is a really friendly guy and normally answers all emails within 12 hours. :wink:

1 Like

I didn’t know that…
Login for CMS: admin | admin

I bought the license on your website and later saw that I should contact Max. I wrote him later and didn’t get an answer yet. Why I have to contact him at all after the purchase is not clear to me. That is only effort for him.

Yes Will, i assume Max is going on holiday too. I didn’t say that I urgently needed an answer. If I had wanted to buy the tool and contacted him first and then didn’t get an answer, I would have asked myself what was going on. Don’t you see it that way?

I also don’t think that the problem is simply WebYep. Then it wouldn’t be usable at all. That’s why I mentioned that maybe I’m making a fundamental mistake or there are problems with Foundry.

I can’t say otherwise. Except that after 6 days I still have no answer. But I am happy when he will soon be back from his holidays. I never expected 12 hours response time, but of course it would be great! But the Redactor isn’t that urgent. I only mentioned that because I don’t know if I’ll get an answer there.

I don’t really want to waste your time with this small talk, but I would be happy if there is a solution for me to be able to use the tool. I think that’s a really cool and simple thing for many users and I would like to thank you in advance for your time!

Redactor is commercially developed and sold software. We cannot just bundle this in WebYep for you. That would be in breach of copyright and licensing rules. We have a duty to protect you, in that regard.

Anyone wishing to use Redactor needs to contact Max using the link on my website, and you arrange with him the name of the user, the website domain name and pay him a small fee to cover the cost. That is the current setup, until the time that the new WebYep website goes live or a new rich text editor is added that no longer has this licensing requirement. It was the same procedure when Tsooj Media previously developed the stacks.

WebYep CMS and WebYep stacks are separate. This is already explained clearly on the website, along with the benefits of why you might choose to upgrade from the free WebYep CMS to the paid variant that includes Redactor. If you do not want to pay the commercial licensing fee for WebYep, then nobody is forcing you to (just change to using one of the non-Redactor rich text editors instead). In the same way that you do not have to buy my WebYep stacks, if you don’t want to (use the code snippets instead).

Understand that the WebYep Stacks, the WebYep CMS and Redactor are 3 separate entities. I only deal with the stacks. Max is responsible for the WebYep CMS and redactor licensing.

Based on the link you have given us, it appears you have put a WebYep gallery inside a 33% wide grid cell. The gallery creates the grid of thumbnail images for you, so there is no requirement for you to build an extra grid to display the gallery thumbnails within. Just place a Gallery stack on the page and let it do its own thing. There is currently insufficient space for you to present the gallery thumbnails - hence they are all jumbled together.

Additionally I cannot see any CSS in your website that scales images responsively. This is commonly added via a CSS reset in the theme or is listed as an optional theme style setting. If your chosen theme is not mobile responsive or lacks support for responsive images, you will need some CSS code in the page like this:

.WebYepGalleryImage img {
    max-width: 100%;
    height: auto;

Now you are getting closer towards something that looks like a gallery:

But you can see how the gallery is only able to grow 33% wide, in the first grid cell? Because you have put the gallery inside a small grid cell. Your gallery wants more space. Ideally the full width of the page.


@willwood Ok, let’s put that Redactor thing aside. This is a bit complicated and I want to use the CMS itself.

A week ago I bought a product called “WebYep CMS Stacks”. This includes the stacks and the CMS for free and legal use, right? Without Redactor and File Uploader.

That’s right! I thought I had to put the gallery in the grid stack. This is also possible, as I see now, but I have to tell the grid that it has to set the number of the cells to 1 for all displays. I tried with and without Grid and it works now. Thank you very much for your detailed support!

I have now tried to use the WebYep image stack in different Foundry stacks. That would be absolutely perfect! But first I’ll have to read a few more things…

If you bought the stacks from my website, then you only got the WebYep stacks. The latest version of the CMS has to be downloaded from Github (it’s an opensource community project) or you email Max to request a commercial version of WebYep CMS with the additional Redactor rich text editor and file manager components.

It took me all of 10 minutes to get WebYep up and running with the Demo stacks, using the video on Will’s page. And a further 10 minutes to purchase the full version.

Same deal as Joe Workman’s Sitelok stacks - you need Vibralogix Sitelok installed on the server. The stacks just remove the need to know what to do with the code snippets.

Question for @willwood: Are you referring to another Rich Text editor that can be used within the CMS, or an external one & Copy/Paste into the site in edit mode?

@jacksona referring to the rich text editors included with WebYep.

Redactor is the default rich text editor. Its controls will only be shown if you own a license for Redactor. Because Redactor is commercial software, not freeware. This is what the controls for Redactor look like:

(Click for bigger images)

You’ve got the choice of ckeditor (available in both the free and paid versions of WebYep CMS) that looks like this:

Some people prefer this one, because it looks a bit like legacy versions of Microsoft Word. To enable it, go into WebYep-system > program > opt and put a ‘-’ in front of the redactor folder and remove the ‘-’ from in front of ckeditor. Now WebYep will use ckeditor instead of redactor.

You have the choice of a third editor called TinyMCE (available in both the free and paid versions of WebYep CMS). But because this is using a CDN hosted version and there are certain GDPR compliance things to follow, you have to enable it slightly differently:

Go into webyep-system > program > editors > rich-text.php and replace all the existing code with this:


	$webyep_bDocumentPage = false;
	$webyep_sIncludePath = "..";

   $oEditorsFolder = od_clone($goApp->oProgramPath);

   if ($goApp->bIsiPhone) {

   // Supported editors.
   $editors = array('ckeditor', 'fckeditor', 'redactor', 'rte', 'tinymce', 'quill');
   $activeEditor = NULL;
   foreach ($editors as $editor) {
      $oP = od_clone($goApp->oProgramPath);
      if ($oP->bExists()) {
         $activeEditor = $editor;

   // If no active editor, fall back to the plain text editor.
   if (!$activeEditor) {


Then go into WebYep-system > program > opt and put. a ‘-’ in front of the redactor and ckeditor folder names. Then you will get controls that look like this:

You may see references in the WebYep system folder to another editor called FCKeditor. I understand this originates from WebYep v1 and is now obsolete. Same with RTE.

Hopefully one of the three rich text editors works well for you. I personally prefer Redactor, but if I was faced with using the free version of WebYep CMS, I think I would opt for TinyMCE. That’s the same WYSIWYG rich text editor that you often see in forum software and comment boards.

BUT - to be brutally honest, I don’t tend to give my clients access to the rich text editor, unless it is absolutely essential. You see, most clients are typically not web designers. Too much creative freedom with things like headings, fonts, alignment, colours and backgrounds can quickly result in terrible text formatting - which can ruin an otherwise decent website. IMO it is far easier and safer to provide only a plain text editor wherever possible and allow the theme to do the styling leg-work.


Thank you, @willwood! Your response is as high-quality as your stacks :+1:

1 Like

That’s good for you, but it doesn’t matter.

It’s all clear now. I bought the stacks from you and downloaded the CMS from Github, otherwise I couldn’t do it here. And I wrote to Max, didn’t get an answer yet and just leave it with the Redactor, even if it would be nice but I can also format the content with tags as usual.

Perfect and a big thank you for your support!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.