Which is the Addons Default Directory, RW 7.0.2


(Mark Sealey) #1

This morning when I launched a RW 7 Project, none of my add ons were in:

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/RapidWeaver

(That’s where they were last night; 100% certain!)

Of course nothing worked :frowning:

They had all moved to:

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/RapidWeaver Container directory

In desperation having quit RW, I manually moved them in the Finder to:

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/RapidWeaver

This time when RW launched it put them into:

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application\ Support/RapidWeaver 7

I still get errors.

I’ve watched this happen now on two machines.

Where should they be, please (no answer from RM in several weeks); and how do I prevent this from happening again.

:-((((


Installing Snapform2 stack fails to install - am on RW7
(Doobox Software) #2

@MarkSealey Not sure how this is happening to you, or how to prevent it, it’s not something I have come across, or heard about.

But you can find and open the correct add-ons folder from within RW7.
From the top toolbar menu select:
“Rapidweaver 7” now hold down alt key on keyboard, and select “Reveal add-ons folder”.


(Robert Ziebol 🖖🏼) #3

You can also get this by holding down command-option and pushing 7


(Mark Sealey) #4

@Doobox and Rob, thanks so much for reminding me of that!

This is what it showed:

There was nothing there. So I moved them all from one of the other locations manually, in the Finder, with RW not launched.

Of course when I launched it, it asked for my licence, which I take as a good sign… comprehensive set of files being put back in the right place.

As a matter of fact, this is the second time this has happened. Oddly, the first time was on an entirely different machine (at work), and then I had to re-install before RW would consistently find the Add-ons.

I put that down to the fact that the ‘Copy Addons from RW 6’ at first installation of RW 7 had failed - it took over 45 minutes, the progress bar kept hanging (that, too, is a clean machine).

For almost three weeks this machine has been stable in this respect; I did nothing in the Finder to this folder; I had no crashes; I was barely using RW; overnight (which really means from the last/previous launch to this morning’s launch) - I am 100% sure - All the Addons moved!

Is there documentation anywhere to suggest which is the accepted/‘correct’/default location for all Addons?


Installing Snapform2 stack fails to install - am on RW7
Difficulties to install stacks or themes
(Mark Sealey) #5

It seems as though each Project has a different idea of where the Addons folder should be.

After everything I did, opening existing Projects gets the error message every time.

Existing Projects seem to be looking each one in one of the locations listed here!

I’ve written to Dan.

I’ve also used the Preference (with no projects open, of course) to Manage Addons in DropBox hoping that RW will update its own internal record of where Addons are supposed to be.

My concern now is this: when I try to perform the reverse/analogous operation on my second machine (work), there is a risk that it will overwrite what’s in DropBox with everything I’ve worked on today.

I also notice that the icons of my Addons are blue not pink (see this screenshot) - or am I misremembering?

I’m sure there’s a way to fix this :slight_smile:


Installing Snapform2 stack fails to install - am on RW7
(Dan) #6

The default location for Addons in RW7 is:

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/RapidWeaver


Copying everything from one computer to another 2018