7.0.4 on macOS Sierra public beta


(Aaron Abernethy) #1

Anyone else feeling brave?

Installed the public beta after the RW7 7.0.4 update notes stated that the Preview crashing issue was now solved specially for Sierra, but now I’ve a new problem.

I can’t see any 3rd party Stacks in the Stacks browser. I tried reinstalling them all, to no avail. Weirdly though I can search for some of them and get results, but mostly the whole thing is empty.

Anyone else had this problem? Am I rolling back to El Capitan again, or should I reinstall RW7 do you think?

Making websites isn’t my job, just a hobby, so this isn’t really critical and I could probably wait until there was a fix if that was necessary…


(Robert Ziebol 🖖🏼) #2

As discussed a few places in the forums already, Realmac is not supporting Sierra right now, until they say they are most developers will not either. Just wait, Realmac will get a beta working when they do.


(Aaron Abernethy) #3

Oh, I saw that, was just wondering if any users had run into the same bug/issue or if I was all on my lonesome with it.


(Brandon Scott Corlett) #4

When I still had a working MBP I used to partition the drive and install the developer betas onto one of the partitions.

This allowed me to play will all the cool new stuff and still have a solid platform to fall back on when I, inevitably, ran into bugs that prevented me from being able to use a program.


(Jonathan Spencer) #5

I have installed it on a ‘spare’ Mac and some stacks don’t show for me. I’m sure it will be sorted eventually. That’s the fun of beta software! I hope you don’t need it for anything serious and hope you made a recent backup of 10.11!


(Dan) #6

We can look into this issue, although I have a feeling it might be something @isaiah needs to fix in Stacks (I could be wrong).

@isaiah any ideas on this?

Cheers,

Dan


(Tom Bradley) #7

I’ve just replicated the issue here and it does indeed appear to be an issue with the Stacks plugin.

As a quick work around (not ideal, but it’s something) if you resize the window it will force the stacks to show.


(Isaiah Carew) #8

yes. there appears to be a redraw issue in the collection view. worse, it’s not 100% clear if this is a bug or an intentional change in behavior of the OS.

i admit i wrote it off as an early beta problem with the OS and was stunned to find this shipped to the public.

it’s tough to know how to move forward in situations like this.

if this is indeed as bad a bug as it seems to be in the OS then the right thing to do is: nothing – as the bug will surely be fixed by Apple soon.

but if this is an intentional change in scroll behavior and not a bug then the right thing to do is to work around this problem.

for now i can only advise a bit of patience with these early betas. there are definitely a few things left to iron out.

isaiah


(Isaiah Carew) #9

OK, so it turns out i was only a couple hours away from solving that one. the universe kind waited for me to totally give up before aligning and showing me the answer. :wink:

I’ve released this as Stacks 3.1.1 beta 8. It fixes this and has some more updates for upcoming RW API changes that are pretty important too. If you’re a bleeding edge beta user, you should definitely check it out.

If you’re watching the Stacks slack channel, then you can grab a copy and join in the testing.

If you’re not yet on the slack channel (or wonder what all these redacted squares are about) come talk to me on twitter or email or wherever. The channel is open to all and a good place to talk about betas and bugs and stuff.

If you’d rather wait for a more stable version, then just give us a day or two to iron out any problems.

Isaiah


(Isaiah Carew) #10

one more thing: Stacks (and all of our products) has an open bug-tracker/feature-tracker. You can find this specific bug here: https://github.com/yourhead/s3/issues/605

if you’re still seeing this bug after installing the new beta mentioned above, let us know, and we’ll reopen it.

thanks,
Isaiah


(Aaron Abernethy) #11

Thanks for looking into this Isaiah, I’ve sent you a message on Twitter about beta access. Appreciate the time you’ve taken.


(GJ) #12

Hi @isaiah - just saw this thread; wonder if 3.1.1 is about ready to go out since its been a couple of days - or if not, if there’s an update on potential timeline (no massive rush, just wondering whether to install the beta just downloaded off your channel or let the weekend pass)

@theronster - RW7 & Sierra have been playing real nice thus far with 2 exceptions reported here. Ver 7.0.4 fixes the preview bit and this thread likely fixes the Stacks-visibility-in-library-pane bit soon. Fwiw - no other issues with RW7 & Sierra (except awesomeness - thanks to @nikf 'n gang, @isaiah & Sierra!) i.e. at least not yet stumbled upon.

@tpbradley Neat tip - thanks for sharing. Odd stuff is, no 3rd party stacks showed by default; then an update check resulted in some stacks showing; resizing window seemed to make default stacks disappear and only select stacks (same as earlier) show up. Really odd thing is, every time UpdateCheck is run, some stacks show up and others disappear - even if there’re no updates(!). And playing around with Library options in the library pane (icon size, sort order, etc) randomly shows some stacks/hides some stacks (no discernible pattern). Can’t seem to show all installed stacks any way - looking forward to Stacks 3.1.1 release.


(Isaiah Carew) #13

@gjug after some important feedback from the Realmac folks I may delay until early next week. I may have been confused a bit on the right way to use some of the fancy new plugin APIs. If there’s room to make it better, it’s worth it to delay a couple days to get it perfect.

The beta is available now though. and if you’re running Sierra I’d definitely recommend it.


(GJ) #14

Thanks for the quick reply @isaiah. Got it. Will start with the beta.