Stacks 3.2 -- Improvements for RapidWeaver 7.1 and Sierra


(Isaiah Carew) #1

We have a new free update to Stacks. This new version includes some changes that will make way for upcoming improvements in RapidWeaver and mac OS Sierra.

I blogged about it in detail here: http://blog.yourhead.com/stacks-3-2-0/

As usual, you can download it from our site: http://yourhead.com/stacks/


(gary pullings) #2

@isaiah

from what I am gathering that this update is more for OS Sierra right?


(Isaiah Carew) #3

@garyp - actually just one tiny change for Sierra – this is mostly to take advantage of all the new awesome RapidWeaver 7.1 API. The blog post goes into a bit more detail – but since RapidWeaver 7.1 hasn’t quite been released yet I can’t say too much yet.


(paolo savonuzzi) #4

thank you, Isaiah

though… 3.2 too does not retain “library sidebar” status: it’s always closed when re-opening a project :frowning:


(Isaiah Carew) #5

I don’t recall changing any code there – but I will file the bug and investigate immediately.


(Bill Hall) #6

Updated to 3.2.0 tonight and for the most part all looks good. But now when I publish, there’s a white space that is cutting into top of banner image. Can’t say for certain its because of this update, but I did update tonight and now this is appearing. It does not appear when previewing in Safari, but does after publishing. This appears in all browsers in Win and Mac.

Setup: RW 6.4, Stacks 3.2.0, Endeavor Theme, Chillidog Hosting - Site: SimStudios.com - 10.11.6

Again, not certain its stacks, but timing is very similar.

Thanks! Keep up super work with Stacks.


(paolo savonuzzi) #7

was already reported for 3.1 :wink:

thank you again :slight_smile:


(gary pullings) #8

I thought that was part of the new update. Didn’t realize it was supposed to stay open. @pl_svn slight_smile:


(Isaiah Carew) #9

@wphall:
It doesn’t appear in preview, but does after publish? Usually that means that something went awry with the publishing process. Here’s what I usually recommend:

http://cafe.yourhead.com/?qa=37/page-looks-preview-rapidweaver-looks-broken-after-publish&show=37#q37

If that doesn’t work, please contact our support folks with more details – specifically if you could share a page in a file that shows this problem that would be very helpful in tracking it down.

Thanks,
Isaiah


(Isaiah Carew) #10

@garyp: sometimes (like when there is an imminent API change to RapidWeaver) we must release after making only a few changes/fixes. That’s the case here. This change to Stacks 3 needed to be shipped in advance of RapidWeaver 7.1 – and fixes a problem that was preventing Sierra users from using Stacks at all. Getting those fixes out was a super high priority and this time had to trump all other fixes and features.

if you’re curious about the state of any bug we have an open public bug tracker. i can see this particular bug is #591 https://github.com/yourhead/s3/issues/591 and it is indeed still open. we’ll get to it as soon as we have a moment to catch our breath after these latest emergency fixes for RW 7.1

Isaiah


(Bill Hall) #11

Thanks Isaiah- Sorry, I should have uploaded images and mentioned that I tried the following:

1 Marked all resources and pages as changed
2 Republished all files
3 Restart machine and did 1 and 2 again

Still no luck. I opened a ticket and included screen snapshots. For now, I’m including it here as well.

Thanks for the help!


(Jochen Abitz) #12

The white space comes from the Google Conversion iFrame.
Does it work if you use this custom CSS-code for this page?

iframe[name=‘google_conversion_frame’] {
font-size: 0 !important;
height: 0 !important;
line-height: 0 !important;
margin-top: -13px;
width: 0 !important;
}


(Bill Hall) #13

@jochenabitz - You da man!

Instead of adding CSS, I just changed the order of the google analytics data within RW. This fixed the problem. Not really sure why it appeared now, but doesn’t really matter anymore. Everything is working great.

Thank you for the tip!


(gary pullings) #14

@isaiah

Actually I like it not popping up all the time. Can we have a function to keep it that way?