7.1.7 CSS being ignored


(Rob Hall) #1

I converted a Foundation project from RW6 to 7.1.7, made some alterations and republished the site (Transmit), only to find that my Google Fonts (and their colours) and my button colours are being ignored.
i completely rebuilt the project (copying some of the more complicated elements over) and republished — with the same result.
Anyone else noticed this problem?
Does anyone have a solution?


(Will Woodgate) #2

If Cloudflare is enabled on the site, you may need to login to your Cloudflare account and purge the cache. By default, Cloudflare only updates its CSS and JS cache about once every 3 hours. So it is likely to miss recent theme and style changes.

Additionally if you are using Chrome 54, it appears that a bug causes Chrome to hang-onto the CSS cache even when the page is refreshed. Going Chrome > Clear Browsing Data seems to fix the problem, as will accessing the page via Incognito mode. I’ve seen the same same issue in both RapidWeaver and concrete5 development sites within the past couple of days, where both were using ‘cache-busting’ style links and Chrome was reluctant to show new styling.


(Rob Hall) #3

@willwood Hi Will, Thanks for taking the time to answer. Sadly neither is the case. I’m not using Cloudflare (but was aware of the cache updates) and the display is the same in all the browsers I’ve tried – even on the mobile.
I’ve tried replacing the CSS files, but nothing seems to work.
My problems began when I updated to Sierra and RW7.1.7.


(Isaiah Carew) #4

A couple shot-in-the-dark guesses:

  1. When you don’t see any of your changes sometimes its a matter of “.html” or “.php” file endings on the primary index pages. In other words, if your homepage was “index.html” and became “index.php” or vice versa – then perhaps both are on your server and you’re seeing the old one.
    If that’s the case, just deleting the older files (or clearing out the host www folder) before publishing should do the trick.

  2. Check your files on your local computer. Are they OK there? If so, then the problem is in the transfer or on the host. If not, then the problem is within the RW export. With that info we can take more concrete steps to solving the problem

Isaiah


(Rob Hall) #5

Hi @isaiah Thanks for taking the time to get back to me.
I had already checked that no conflict between .html and .php is occurring. I also cleared out the host’s www folder a couple of times
The files are o.k.on my local computer I also compared all the local files to the remote files and they would seem to be identical. My RW preview looks perfect. Should I deactivate ‘Consolidate’ and ‘Minimise’ in the advanced settings – doesn’t seem to make sense?


(Isaiah Carew) #6

ok, there’s a few contradictory bits of info there:

  • the files look ok on your local computer
  • the files do not look ok on your remote host
  • the files are identical

one of those pieces of info must be incorrect.

and i think this sort of has to come down to how you’re looking at things and measuring their ok-ness and same-ness.

i’m guessing that the problem is only seen when visiting your site. that’s a bit different than looking at the files directly and involves a few more interesting steps and things that might get in the way of seeing the real info:

  • your browser cache
    try clearing and disabling the cache. try another web browser entirely. try another computer. try your phone.

  • caching services (CloudFlare, Akamai, etc.) these services cache your content in many places around the web a serve it faster – but can sometimes become confused about when the cache needs to be updated. if you use any of these sorts of services, disable it complete (remove all of its code from the site) while debugging issues like these.

  • hosting shenanigans
    it could be your host has its own cache/speed-boost/clever tech. same as cloud flare. disable that for now.

  • hosting folders
    more than a few times (even myself) i’ve seen people accidentally upload their files to a folder on the wrong server – or the wrong folder on the right server. the files seem to go. everything seems in order – but the site remains unchanged. i’d look for obvious mistakes like that. a good way to double check is to temporarily replace the content of the index.html with “Hello World” – can you see the change on the site – if so then your it’s the right folder/host – if not then double check your folder/host is correct.

Isaiah


(Rob Hall) #7

@isaiah Thanks for taking the time once more.
Contradictory: The files look the same both locally and on the remote server.
The display is fine when I view it locally, but incorrect when viewed on the server.

I tried all the usual such as disabling the cache, using different browsers and different devices. My server caching service is disabled and the problem has existed for around 14 days, so caching shouldn’t be an issue anyway. As for uploading to the correct folders — I deleted the site more than once and republished. I use Transmit to upload and always check the upload path meticulously. And any changes I make to the site are reflected correctly, with the exception of my fonts and colours.

The strange thing is — when my pages are uploaded to a different server (Robb Ziebol tested this for me on his server), everything looks just fine.
You can check the difference here:
http://rapidweaver.ninja and
http://www.zeebedesigns.com/ninja-test/


(Isaiah Carew) #8

Your page still seems to have cloudfront active. And is vastly different from the page published on Zeeb’s site.

Evidence for it being a cloudfront problem seems pretty strong. I think I’d keep investigating that angle before looking at anything else.

Isaiah


(Rob Hall) #9

I removed the code for GoSquared and also removed the settings to consolidate and minimise CSS/Java — no difference.
The discrepancies between Robb’s upload and mine are due to the fact that my header image is in Resources, so Robb would;dn’t have had it — also — not all of the elements from ‘Final Word’ were uploaded.


(Isaiah Carew) #10

Ok. Welp. My guess looks to be totally wrong. Sorry for sending you in the wrong direction. So much for this expert stacks guy. :wink:

But now that I’m eaten my humble pie, I think what I’d try next are some of the advanced settings.
Settings > General (scroll to bottom > Click Advanced…

In specific: CSS consolidation, cache busting links, minify css/js and tidy.
i might try switching everything off just to see if it changes the behavior at all.


(Rob Hall) #11

Tried your suggestion @isaiah and now I’m nearing the end of my internet allowance (I live in the Thai Jungle and my only connection is via mobile). Will need to wait 'till mid-month now to look further into the problem.


(Isaiah Carew) #12

if there’s any way for me to help out with that, let me know. would be happy to accept a thumb-drive via snail mail. :wink:

also: the Thai jungle sounds amazing right about now.


(Jason Bostick) #13

Yeah, what’s up, America? That was a crazy night last night


(Rob Hall) #14

@isaiah MANY THANKS for the time you spent looking at my files, your advice was indispensable!
My site now looks the way I designed it to!
I can’t thank you enough for your support.


(Isaiah Carew) #15

no problem. glad i could help. and i think we got your overall system a bit more streamlined in the process – so hopefully the next project will be smoother too. :smiley: