Add To Cart button has suddenly stopped working

Hi, ive just discovered today that the add to cart is not working on any of my products. it was fine last time i checked and i have made no changes to the site. Does anyone know whether its a problem with rapid weaver / rapid cart or if I have an issue to go to my hosting service to solve? Not computer savvy so don’t really know how to describe the problem if its an issue with hosting.

You’ll need to provide a link to website/page where the issue is.

this is one of the product pages. it works fine in the rapid weaver but not online once its published

There are a few errors in the Safari console. Have you published or republished something recently?

You might want to try republishing all files.

I added that new product a couple of weeks ago but as far as I’m aware I’ve done exactly the same process as usual. Unfortunately I don’t really understand most of the errors above. Basically I’m not any kind of web designer but my business is too small to be able to pay someone else to do it. It’s fine when it’s working but when things go wrong I have no clue.

republishing all files doesn’t seem to have fixed it either. Hosting service is unavailable for support until the 6th due to some kind of ticketing system upgrade. switched to PHP 7.0 from 5.6 incase its anything to do with that bt can’t see why it would be as its been working fine on 5.6 until now.

Maybe @rob can help?

The “Add to Cart” button works correctly.

hi, thanks fir looking at this.what were you viewing the site on? I republished all files and updated the PHP option on my hosting service to PHP 7.0 from 5.6. I then found the add to cart button worked on the iPhone version of the site but the cart got stuck on the NEXT button when you entered your email ready to make the purchase. On safari on Mac and when i meow on the ipad. I can’t get the add to cart to work. i have cleared my website history and cache so i loading the most recent published version. I can’t work out what has changed as it worked up until now ok.

Please report exact steps to reproduce the problem.
BTW I see that you have network problems on your website.

the site is up at the moment. perhaps you checked it while I was republishing all the files. it did stop working for a few minutes. I’m very confused by it all. I’m running it on rapidweaver 8 & rapid cart pro 4.18.4

I get this couldn’t sign into FTP server message all the time when I publish but it just retries and seems to work on the next attempt. it has always done this but the cart has been working fine until now.

I confirm that I cannot proceed beyond “Address” section in the Cart.
RapidCart Pro doesn’t correctly handle the request due to a misconfiguration on your website.
If you say that RapidCart Pro worked correctly before, I need to know what has changed when the problem started to appear.
RapidCart Pro update? PHP update? A change in server configuration?

I have updated rapid cart pro but I did that this this morning thinking maybe updating would resolve the issue. I have also migrated from RapidWeaver 7 - RapidWeaver 8 (again, wondering if my older version was becoming incompatible with Catalina and the latest iOS software) but it hasn’t helped. I updated my PHP with my hosting from 5.6 to 7.0 but these steps were taken after I found it wasn’t working. I know logically something has to have changed but as far as I am aware, all I have done is add a new product to the shop. If I have changed a configuration it has been unintentional. I apologise for my lack of detailed knowledge.

I have published an old backup copy version of the website to see if that had issues. I know that version was working at the time i made the copy and it had the same problem. Does that indicate that something outside of the website has changed with my hosting or within safari which doesn’t like my current configuration

Okay! I can now confirm that both my websites (hosted by two different companies)are experiencing the same problem with the shopping pages. I have not made any changes to this site for a couple of months. I’m sorry to bombard you with messages but I do not know where else to turn for help.

You made no changes to your store and suddenly it stopped working.
Sorry but you need to find out with your hosting provider what change on server side caused the problem.

1 Like

I’ve discovered that the multi themes Label X has stopped working with rapidcart. I temporarily changed the theme to Lander and the cart is now working. I will have to get to the bottom of it as my site has been designed to fit their theme template. I have got in touch with support at Multithemes as this has been working fine up until now to ask what might have caused a conflict.
Thank you for taking the time to replay to me about this.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.