RapidCart Pro problem


(Terry Vosbein ) #1

I am having trouble with the “Add to Cart” button on my website. It seems that pressing it has no effect. But if i go to other products, and keep clicking “Add to Cart,” eventually one works, and then all of the others work. I can’t expect customers to click willy nilly until my site works. I do not know if any of the recent updates have effected it. I use Foundation, RapidCart Pro, (and RW7beta) with the most recent updates to all.

Here is the site in question:

Any help would be greatly appreciated.

Terry Vosbein


(Roberto Tremonti) #3

Hi @TVosbein ,
website address in your project settings is not correct and this prevents AJAX requests from wroking correctly.
AJAX requests are basically blocked by browsers for security reasons.

Please change http://maxfrankmusic.com to http://www.maxfrankmusic.com (with www at the beginning).
Then republish your website.


(Terry Vosbein ) #4

Thanks for the response. I published the site to www.maxfrankmusic.com, but it did not work. I was always directed to the files uploaded to maxfrankmusic.com.

When I removed the maxfrankmusic.com files from the server, and typed www.maxfrankmusic.com as the url, i was directed to a 404 page, even though I had uploaded my files to www.maxfrankmusic.com. All traffic goes to maxfrankmusic.com, and I had removed it.

I spoke with my ISP provider. They told me that the folder www.maxfrankmusic.com, that RW created when I published, is a subdomain of maxfrankmusic.com. Publishing to www.maxfrankmusic.com will always show maxfrankmusic.com. All they could do was to direct any traffic for www.maxfrankmusic.com to maxfrankmusic.com, which they did

But it still does not work.


RapidCart Pro issue
(Roberto Tremonti) #5

Again, just update your website address.

Your website address in RapidWeaver settings panel is set without www.
http://www.maxfrankmusic.com/rapidcartpro/index.php?checklist/page

Add www to the address and republish the page.
If your RapidCart Pro page is not published, you can force republishing from RapidWeaver menu.


(Terry Vosbein ) #6

I really appreciate your help with this. I did update the web address in RW. It is there now, on the Host’s server. But on the Host’s end, all traffic goes to the site without the www. The www site was inaccessible through a url, because it is a sub domain on my Host’s end.

I just talked to them to have them change the default location to the www address. They say it may take 24-48 hours to change over. I will see what happens then.

I wonder, though, why this started happening, as I have used RapidCart successfully for years on this site, with RW6 without the www. Could there be a hiccup with RW7 (which I am currently using)?


(Terry Vosbein ) #7

I have published to www.maxfrankmusic.com and the cart still doesn’t work. I do not know why all of a sudden Rapidcart ceases to function with the publishing settings I have used successfully for over a year.

Do you have any other suggestions?

Or has anyone else had this problem?


(Terry Vosbein ) #8

When i click on “Check your displayed page” i receive this error: Set a valid URL as “Web Address” in RapidWeaver project general settings, then republish your RapidCart Pro page before trying to access it.

I did not receive that error message whenI I published to the URL without the www.


(Roberto Tremonti) #9

Again, your website address is set to http://maxfrankmusic.com/.
You need to set http://www.maxfrankmusic.com/ (with www in address) as Web Address in RW General Settings!

http://www.maxfrankmusic.com/rapidcartpro/index.php?checklist/page


(Terry Vosbein ) #10

Again, my website is published to www.maxfrankmusic.com.

www.maxfrankmusic.com is a sub domain of maxfrankmusic.com

There are no files published to maxfrankmusic.com. The only files are published to www.maxfrankmusic.com.


(Gilberto De Faveri) #11

This is why your project Web Address must be set accordingly, as explained in RapidCart Pro manual:

https://tls.4gnd.com/rw/rapidcartpro/manual/#introduction/requirements

Is your project Web Address set as described by @rob?


(Terry Vosbein ) #12

Forgive me for misunderstanding. Rob kept telling me to change the setting and publish to www. I changed the publishing settings and it didn’t work. It was only after re-reading Rob’s final message, still stumped, that i realized that it had to be changed in two places, publishing AND general settings. I am sorry missed that, but it wasn’t made clear that I had to change it in both places.


(Roberto Tremonti) #13

Nevermind. Glad to know it’s fixed now.