Adding Resources


(Chris Anderen) #1

Using 8.3 and whenever I try to add a resource by dragging to the appropriate folder, the app crashes. If I try to pick the file by using add files, it looks like its going to work (+1 in green) but it is not there. Either way, I’m stuck as a bump on a log.


RapidWeaver 8.3 Public Beta 2 (Build 20780b)
(Chris Anderen) #2

Here’s the start of the crash report
Process: RapidWeaver 8 [67250]
Path: /Applications/RapidWeaver 8.app/Contents/MacOS/RapidWeaver 8
Identifier: com.realmacsoftware.rapidweaver8
Version: 8.3 (20780b)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: RapidWeaver 8 [67250]
User ID: 501

Date/Time: 2019-07-09 16:08:23.941 -0500
OS Version: Mac OS X 10.14.5 (18F132)
Report Version: 12
Anonymous UUID: 8F9CF1B8-C14B-22C3-2259-927E720B4221

Sleep/Wake UUID: C2EAB277-8FB5-4638-B700-862338B22A10

Time Awake Since Boot: 3800000 seconds
Time Since Wake: 2800000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [67250]

Application Specific Information:
Crashing on exception: *** -[__NSDictionaryM setObject:forKeyedSubscript:]: key cannot be nil


(Doug Bennett) #3

Looks like you are running the Beta version of RapidWeaver (Version 8.3 (20780b)).

I just did a quick test (also on the Beta) dragging a folder into resources with another folder open and didn’t have a crash.

So it doesn’t get overlooked, you would be best to report on this Thread:

They will probably need more info and a copy of the project file.


(Chris Anderen) #4

I think it has something to do with my resource file. Don’t know anything about that, but this morning I had a crash when there were folders that were blank. Cleaned that all up and it worked until I started to try and add files to it. Weird parts is if I drop, it crashes. If I use the add files, looks like it worked but doesn’t.


(Riky) #5

The lastest 8.3 beta 2, when having folders in resources, all projects I open removes the name from resources folders.

For me the solution is to open the Project in 8.2, make a screenshot of the folder names, then update to 8.3 and put the same name again on the folders, then save, close the Project and then it Works ok.

Also when opening a RW7 in the automatic conversion for a new RW8 Project, the new Project also has no resources folder names, they simply are blank.

Maybe the next beta corrects this bug.


(Chris Anderen) #6

I had that too. Renamed folders but when I try to add, it crashes. They need to fix that part. How do I go back to 8.2?


(Doug Bennett) #7

Down load old releases here:


(Chris Anderen) #8

Thanks. I also got all of my names back on the resources file and can add again. It’s a bug in 8.3 for sure.


(system) #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.