RapidWeaver 8.3 Final Candidate 2 (Build 20786b)


(Tom Bradley) #1

Hey Weavers,

Here’s the latest build of RapidWeaver 8.3 which has an important fix for the ‘Untitled Folder’ issue. We’re sure this one is ready for prime-time, take it for a spin and let us know what you think.

What’s New in 8.3

  • [NEW] Fixed an issue where an ‘Untitled Folder’ directory could be seen in resources
  • [NEW] Fixed a crash when adding new resources if existing resources are unresolved
  • Fixed a crash in the link panel
  • Fixed a crash when dragging a resource into site settings
  • Fixed an issue where the blog social images would not be saved
  • Added new update engine
  • Added support for Emporter
  • Updated Multi Lander Theme
  • Added support for detecting and managing duplicate images
  • Various other under the hood tweaks and fixes.

Download RapidWeaver 8.3 (20786b) Final Candidate 2

Happy Weaving!

Cheers
Tom


RapidWeaver 8.3 Final Candidate 1 (Build 20780b)
(Dan) #2

(jol yates) #3

I am always happy to contribute - but you have to listen

Whilst you have successfully removed the “Untitled Folder” from the resource path … links now point only to the container and not to the file within as required.

I won’t support betas going forward if such errors cannot be nimbly rectified


(Trond Grøntoft) #4

Not really listening is of course an option here. But code can be complex. Some bugs only show up in certain contexts.

I’m pretty sure the developers wants this problem out of the way as much as anyone else, so I think giving helpful details is the best way to get this problem solved.


(jol yates) #5

Thank you so much Trond for your most helpful reply. I am fully aware of the demands on the developers.

I have availed myself - as ever - of my time, my support and my working files. Given that this is the ‘second final candidate’ and still cannot address resources, I am unsure what more I can add to this.

Jol


(Jan Fuellemann) #6

Does this still happen when you republish all files?


(jol yates) #7

Thanks Jan - Good comment !

I have not tried republishing all files - so perhaps I should do that now

However, when I right-click “preview page in Safari” etc - it fails

Will upload entire site and report back Jan

Jol


(jol yates) #8

Thanks Jan

I re-uploaded everything and cleared my cache too

The resources still link to the resources folder - as you will see if you click on this example ‘READ MORE’

Thoughts welcome

Jol


(Jan Fuellemann) #9

Thanks - if you relink the files now, with the latest beta, it should be ok again?


(jol yates) #10

Thanks Jan - but still no cigar

Link previewed in safari / chrome includes no file (just the enclosing ‘DM-News’ folder)image

Link live in Safari (also shows only folder)
image

Actual resource as linked

Opens folder (- But not the linked file). From this folder - you can select and load the correct file (proving it’s there)


(Joe Martin) #11

It is linking to the folder…not a file.


(jol yates) #12

indeed Joe … but why ?


(Joe Martin) #13

What file are you linking it too?


(jol yates) #14

See “Actual Resource as linked” above

I’m linking to …

‘DYD_August_2017_Newsletter.pdf’


(jol yates) #15

I appreciate any support here Joe !

I’m clearly going mad


(Joe Martin) #16

The code says it is not linked to that item:


It would be much more efficient to put all of those in a folder on your server and not blot your RW project file.


(jol yates) #17

Thank you Joe - my linked files are indeed … not linked anymore

All my resources reside in the ‘resources’ folder on my server

If I am ‘blotting’ my RW file by using the the resources feature - then the resources feature is compromised.

You are suggesting I relink all my resource files directly to source URLs and not use the resource feature at all ?

This would probably take me weeks !

I appreciate your input


(Joe Martin) #18

Yes I am…anything in resources exist inside of your project file…so as you add more and more the project file keeps getting bigger and bigger…I use the resources folder but not for photos or files to be viewed. They take up too much room. The resources area works as intended…but you are using it outside of average usage.


(jol yates) #19

OK - Interesting perspective Joe

  • I would welcome such acknowledgement from a member of the dev team

My file size is big at 71Mb

Is that so big though ?

It doesn’t really explain to me why some resource links work and some not.

Should the Dev team say you can only have 50 resources ? What are you suggesting ?


(Joe Martin) #20

I agree…I see that some of yours do work…???
71Mb…I keep mine in the 3-10 range!!!