Adding Stack Crashes RW8 - Peek-A-Boo Stack anybody else?

Hi all, in a bit of a sticky wicket, bought Peek-A-Boo Saturday morning as I need it for a project, (Target/Content) but when I drag this stack on to the page RW8 crashes out and generates a crash log.

I have Catalina MB Pro and an older carry round High Sierra MB (for places where my MB could get nicked). RW8 and Stacks 3.5. Both MBs, RW and Stacks have all the latest updates installed so are as up to date as can be.

Whether I add to an existing project or a new blank project RW8 crashes when I drag PeekABoo launcher or content from the library to the page. I have quite a few 3rd party stacks and none of the others do this and it occurs on both the Catilina MB Pro and High Sierra MB Air, so it can be narrowed down to either RW8, Stacks 3.5 or Peek-A-Boo.

Has anybody else experienced this?
Or similar with a different stack?
If so did you manage to do anything to get it to work?

I’ve tried every possible scenario to stop the crashing but it happens everytime.

I put a support request in to Joe on Saturday with a screen recoding and crash log and then thought yesterday I should send also to Yourhead as this may be a problem they may want to look at.

I’m in a bit of sticky wicket now as I’m tempted to buy Elexir Graphics Capsule as that looks as though it will do what I’m after, but don’t want to spend more money only to find this problem gets fixed and then I’ve spent twice on similar/identical products, but I can’t also keep my project hanging around waiting, also if I end up buying two products simply because the first won’t work and have no idea when and if it will ever, I’m going to feel like a bit of a mug.

On a side note, this is good argument for watermarked/restricted demo trial products.

I do fully appreciate though that time zones, the nature of developers being more or less a ‘one man band’ operation with multiple support requests and then trying to determine the problem in the triangle of products RW8, Stacks 3.5 and Weaverspace is no easy feat. So please don’t think this is critisicm or moaning of service, all developers in the RW community have been fantastic in any form of correspondence in any past communication. Just want to get to the bottom of this riddle.

I’m sure @joeworkman will be getting back to you soon, he’s usually great at support.

In the meantime have you tried restarting RapidWeaver and then starting a new empty project with a new blank stacks page and try dragging the stack on the page?

I have peak-a-boo but I’m running stacks 4, so I can’t check it out with the same setup as you.

Hi Teefers (Doug), thanks for your reply, I am confident Joe will get back, I know his support is really good and he is a genuine guy, hence why at the end of the post I wanted to make it clear I don’t want to bash anyone on a public forum, I fully realise tending to every request is time consuming, when also needing time to develop also. So thought in the meantime I’d see if anyone else has experienced this or similar and fixed.

I’ve tried restart, update check, new project with no other elements on a clean page, virtually every possible scenario. I don’t really want to upgrade Stacks yet as it works fine for me at the moment and was not that long ago since I first bought it really and then find it still happens with Stacks 4 (for me). There is no requirement notice for Stacks 4 with PAB so don’t really want to purchase just yet.

If it’s crashing RapidWeaver with an empty project and an empty page, I’d try re-download the stacks from Joe. If that doesn’t fix it I’d go ahead and cut a support ticket with YourHead (@isaiah).

Thanks for the tip, just uninstalled, reopened to check library that it is uninstalled, re-downloaded and reinstalled. Full quit and fresh open of RW between each stage, still same problem, I’ll wait to see what feedback I get unless anybody else in the meantime has experienced this or similar.

@TopHat Like Teefers I have no problem with Peek-a-boo and RW8 with Stacks 4. I don’t recall any problem at all when using Stacks 3.

… so I doubt the problem is Peek-a-boo per se. Perhaps it conflicts with “something” in your setup. We have no idea what theme or framework you are using. Not about extra code added. etc. etc. My guess is this can only be resolved with @joeworkman or @isaiah. One of them may need to take a look at your project file.

Thanks Matthew, fully get what you are saying, the framework is Foundation (not 6 though). No extra code added, certainly not on a new blank project.

I think that its Peek-a-Boo. It looks like I may have added some Stacks 4 APIs to PAB v2.0 but I accidentally also shipped updates to Stacks 3 users. There are 2 solutions…

  1. Email my support and I will get you a copy of v1.x
  2. You can upgrade to Stacks 4.

Let me know what you plan on doing. Sorry for the trouble.

Thanks for getting back Joe, that’s great news, (not that I have to upgrade, but that the there is a solution to the riddle :wink:). I think I’ll upgrade to Stacks 4, it will need to be done at some point, was hoping to skip a version, but I see this could occur more frequently as time progresses with add ons.

Hopefully this post will work well for others that may face the similar situation with this and other stack add-ons.

I’ll add a note to this when done to let people know.

I just repaired my updates so that Stacks 3 users will stay at PAB v1.x.

Sorry about that. Stacks 4 is really great. You are going to love it.

Upgraded to Stacks 4 now. All good and working, there you go folks, there is a lesson to be learned, stay up to date.

Thanks Joe, Teefers, Matthew for contributing with help.

Joe you can scratch that support ticket off, the one with the crash log and screen recording.

Oooh, my world has just gone all multi-coloured flat icon… Right let’s see what’s new… Externals? Bring it on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.