Stacks VERY unstable :-(

Since some of the later updates, my installation became very unstable. Dragging stacks on the page is always a risk, very often RapidWeaver crashes (no crash log, unfortunately) and all work is lost. This happened in the last two hours about 4 or 5 times to me.

I can’t put my finger on it, but I believe it happens more frequently when I have preview windows open.

It doesn’t matter what theme and what stack I am using, no matter if it’s a simple page or complex page.

With this situation, the application is not usable for any productive work :frowning:

@isaiah is this something for you or for the RW team?

Same here. It often happens when I try to copy stacks from one project into another. I think the problem started with RW 8.7 but I‘am not sure.

Out of interest, what version of the operating system are you two using?

I am running Big Sur.

Without details about what is causing the crash, it’s very difficult to say for certain. But your description sounds similar, at least on the surface, to a bug I’ve been working on.

So, as a test, I’d like you to give a new beta I’ve been working on that I hope will fix two of the most common crashers. You can download it here:

https://yourhead.com/appcast/RW6/beta/Stacks4/Stacks_4.2.0b3_5457.zip

I know that some folks want to stay away from beta versions, so I usually don’t post these to the forum, but I’d really love some feedback from someone that is experiencing this crash regularly. And if it does help with the issue, it would be a quick and easy way to get you back working.

If it doesn’t help, report back that info and we’ll work on further analyzing the issue. By sharing your RW environment I’ll be able to see more about about your project(s) and the installed addons and perhaps help you uncover what is causing the issue.

Isaiah

I know, I would be happy to give you more details, a crash log would help. I try keep the console open, perhaps there’s some more insight.

I am giving it a try. I started yesterday continuing my work without previews open, so it “feels” more stable now. Once I got a decent state on my project, I will try to reproduce the behavior / crashes.

@dripple Big Sur? Damn. I was hoping you’d say something older. On my main machine, I’m still running Mohave and haven’t been able to go near any version of 4.1.x, but I updated my MBA to Big Sur and with 4.1.4 (I think) it’s less crashy. Still crashing, but less so.

@isaiah I will test the beta too and get back to you if it fixes anything. I have a test project that I know invokes crashing when I do certain things, so it’s a sure-fire test, for me at least.

EDIT: Nope. Just tried it, restarted RW etc. Still able to invoke a crash by cutting and pasting a section of content. Didn’t test further.

I was on Mojave untill the very last days. Apple “forced” me to upgrade to Catalina and then quickly to Big Sur, otherwise I couldn’t submit iOS to the app store :frowning: (I had loooots of problems with file permissions after upgrading to Big Sur, this “read only os” is a nightmare, no matter how secure it is.

And this could easily be the cause the instability as well. If there are resources in a project that you no longer have access to. Or if Big Sur thinks you don’t have access to some items inside the RW Addons folder things can become very unstable.

Also: after a big update it’s worth just removing as many plugins as you can. I’ve seen situations that trick RW into not updating a specific addon (like there’s more than on copy of it installed) and that old addon causes problems.

However your description of “crashing while dragging” is similar to another user – and that’s the bug that I’ve been targeting.

But I’m surprised by no crash reports. You don’t see the little alert after RW crashes saying “RapidWeaver Quit Unexpectedly”?

As described, it happens only with dragging around Stacks. Everything is smooth as expected. Haven’t had the time to install the beta, but will keep you posted.

Nope. RW just closes without warning, and after reopening RW acts as nothing has happened…

I’ve had a few crashes lately and the ‘Quit Unexpectedly’ window pops up about 3 minutes after I have re-opened

3 minutes seems long, but i think it’s been that way for me to – at least once or twice. i really don’t understand what triggers the alert window to pop up on macOS these days. it seems to happen at all sorts of different times for me and i haven’t been able to see the pattern.

however, you can always click the “Report” button and copy and paste the info here or to a private message or slack or wherever.

i would be especially interested to see data back from the beta version. it’s new as of Sunday afternoon, so i have not had any feedback yet.

Isaiah

2 Likes

I’ve updated the link above with this morning’s build. I think it’s a significant improvement.

If you’ve already downloaded and/or installed the beta, then RapidWeaver should inform you that beta 3 is available via auto-update.

And here’s a direct link, just in case.

https://yourhead.com/appcast/RW6/beta/Stacks4/Stacks_4.2.0b3_5457.zip

This latest build moves the stack rendering queue back to where it was just prior to v4.1.0 – and I think there’s a pretty good chance this is the source of the crash.

3 Likes

Thanks, @isaiah. Going to give it a try later.

Any feedback on the crashing?

I have only received three reports. All OK – but no one has confirmed the bug fixed or said the crashes are still occuring. So I’m still sitting on the edge of my chair to decide my next move.

But at least all have confirmed that this “universal” build (works natively on Apple Silicon) is OK – no drastic changes in big projects. I’ll take that little bit of good news as at least one positive step forward.

1 Like

Still crashing for me.

Do you have a crash report I could see?

I’ve done some work on one of my private sites, converting it to Foundy, so lots of stacks pushing around and it worked so far, however, I didn’t take the risk and left the preview panes (i typically have two 15" and iPhone 8) always open.

when you say, “leave preview pane open” do you mean the “Simulate” button?

Pasted_Image_2_9_21__1_44_PM

And how is your simulation window set up? Details like these probably make a pretty big difference. If I can duplicate your setup I may be able to see the behavior that you normally see.

I think there’s a built-in “MacBook Pro 15” setup for the simulation. I’ve set my test to leave that and an iPhone 8 window open.

That seems like a good setup.