Agent stack crashes RW

Upon loading RW I noticed the alert that there were a couple of stacks updates. One of the two was Joe Workman’s Agent stack. So, of course, I upgraded. However, once I did, RW crashed every time I selected the agent stack which made it impossible for me to do any further work on my site. I submitted a ticket through Joe Workman’s Zen desk several days ago, but as of this writing, I have had no reply.

Dissapointing.

So I eventually solved the problem by using Time Machine to revert back to the previously installed version. That solved the problem.

Has anyone else experienced this?

I don’t have Agent Stack, but it might help @joeworkman figure out what might be wrong if you could provide what version of RapidWeaver and what Version of Stacks you are using.

Good point!

I am using RW 8.7
Where can I display the stacks version?

Add on manager (button on tool bar or under preferences) > Addons > Plugins > YourHead Software

Thanks!
Version 3.6.7b1


The b1 would show that you are running a beta version of stacks 3. The last version out for stacks 3 was 3.6.9.

You can try to update to that and see if that fixes the problem. All older versions are available for download here:


Now I don’t have Agent, and I can’t find anywhere on Joe’s site where he lists the requirements for his stuff. Most of his later stuff requires stacks 4. (that would be a paid upgrade from 3).

I don’t know if that’s the issue or not.


Thanks, Doug!
So… I frequently shut my brain down for maintenance, so forgive me if I seem a bit slow, but I can’t see from your post where to download the stacks versions. I went to the YourHead website but I can’t find a link for it there. Isn’t RW supposed to check for the latest versions?

Upgrading to version 4.X isn’t appealing to me. Except for the publishing problems I am having, everything is working OK and past experience has given me PTUS (Post Traumatic Upgrade Syndrome)

The link I gave above (not on a line by itself http://info.yourhead.com/stacks/), just scroll down until you get to stacks 3). That page is also in the footer of every YourHead Page (YourHead Archive). Also in the footer is the link for serial number lookup, in case you need it.

I don’t know if that is going to solve the problem or not. I know Joe is going full bore with Stacks 4, but I can’t find that as a “Requirement” on his site.

His old site made things like stacks version, php versions very clear.

I think when you go the Beta route it stops working for some reason.
But on regular (non-beta) versions it still works for me.

Thanks, Doug!
I always get such great response whenever I post on this forum. I downloaded the latest of V3, but I am skittish about upgrading the Agent stack until I get a reply from Joe. Thanks for your help!

When I shipped Agent 1.6.0, I used a Stacks API that requires Stacks 4. It slipped my mind to set the min api in the stack. Therefore my update server supplied the update to Stacks 3 users as well.

If you need the older version, I can get it to you if you email in.

However, you will receive no further updates to Agent (and a lot of my other stacks) unless you upgrade to Stacks 4.

Joe, I reverted to an earlier version using Time Machine. Upgrading to Stacks 4.0 will cost me $44.42 CAD. What I have now is working fine for what I need to do. Every time I upgrade something, something else stops working. This usually requires me to update those items as well. I think the software upgrade business is somewhat coercive. Imagine buying a new car, taking it in for repair, and being told that the parts are not kept in stock for more than two years, but you can upgrade to a new car with your old car trade-in. My point… people who have invested in software should be supported for older versions. At some point I will be forced to upgrade, but I will need a really good reason to do that.

Glad that you were able to restore from a backup. I have fixed the update server so that you should not receive updates to Agent that do not support S3.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.