Always asking for Serial Number


(Paul Ricci) #1

Good day.

I sent this question to Realmac, but based on the time difference between myself and Realmac I wasn’t sure how long before I’d get a reply so I thought I’d try the forum in the meantime.

I was having an issue with RW 6 recently and just decided to remove it and reinstall fresh.

So, I deleted the app and the com.realmac folder in Library->Containers.

I re-installed RW 6, registered it, and then did the upgrade.

After the upgrade it restarted and again asked for my serial number.

I then installed one plugin, quit RW 6 and restarted it. It again asked for my serial number.

So, I installed 2 other plugins, restatring RW 6 in between each install and each time it asked for my serial number.

Now, before I go and delete everything again, is there something I should have done before trying to reinstall RW 6 that I may have missed?

Thanks,
Paul


(Mark Sealey) #2

Paul,

I’m sure that someone at RM will reply soon to help you.

In the meantime, you might want to try an app like AppDelete, which makes a better job of feretting out all of an installed application’s files than you or I could.

It may just be that there are some prefs, dependent library files - other than those which you removed/replaced - that are causing the behaviour you’re experiencing.


(Aaron Marquez) #3

We never recommend removing the preference files, as those are only for serials/licenses, preferences, etc.

Just replied to your email as well - can you try restarting your computer?


(Nik Fletcher) #4

A quick addendum to @Aaron’s post.

Removing the “Containers” folder is tricky - if you remove the folder, the preferences system that apps make requests to has no idea where to actually write these preferences to. So it holds on to them only while the app is open

So. If you must remove the Containers -> com.realmacsoftware.rapidweaver6 folder, you really must restart your Mac to get things back in line before you launch RW6 again!

—N


(Paul Ricci) #5

Problem solved - the restart worked.

Thanks


(Aaron Marquez) #6