Re-activate license each time I open RapidWeaver 7?


(Alice Antonov) #1

I just installed RW7 on my Mac and it’s now having me re-activate the license each time I open the program. I’ve uninstalled and reinstalled RW, and restarted my laptop but nothing’s helped. My Mac uses OS Sierra 10.12.2, and it’s the second laptop to use the RW license I purchased.

Is there any sort of solution to my problem?


(NeilUK) #2

If you look in the main RapidWeaver menu, there’s a registration option under preferences. Maybe registering RW through there might help if it not registering.

Other than that, can’t think what it could be.


(Alice Antonov) #3

Nope :confused: - just tried it and still getting the same problem.


(Dave) #4

I sort of get the same thing about once per week, but my issue is limited expressly to Stacks. I have to re-input my v3 serial followed by v2 serial. Then, I have to reset my stacks preferences. No rhyme or reason as to when it happens…but it’s all-too-often.


(Mark Sealey) #5

Two thoughts occur to me:

1 - when you say ‘uninstalled’, Alice, could that have been incomplete such that RW is hanging onto some sort of partial 1 - previous registration data?

2 - there is a limit at RealMac’s end to the number of installs allowed on various client computers; could your various installs and uninstalls have fallen foul or even confused that count? Suggest contacting RealMac.

Good luck!


(Alice Antonov) #6

I’ve completely uninstalled it - and had my software engineer dad do the job to make sure no mistakes happened.

But this is an upgrade to RW6 - so everything from RW6 got moved to RW7, so it might be something rom RW6 is messing up RW7?

I’ve contacted RM already, hopefully they’ll get back to me soon.

Thanks for all your advice :slight_smile:


(Mark Sealey) #7

Alice - because Res 6 and 7 are substantially different, it could be that there is something left over from 6 that’s prompting you. Good luck!


(scott williams) #8

Probably best to wait for an answer from @dan ,@ben or someone in support. Does it let you go on and function?


(Jannis from inStacks Software) #9

I had the same problem in the past, with an older version of 7.1 I think, wen the MacBook was not online.

This was fixed and does not happen any more with the latest 7.2.2 release.


(Alice Antonov) #10

I’ve downloaded the latest version so I have no idea what could be causing this problem. RM got in touch and told me they’d reset our license code but it hasn’t worked. So I’m just waiting to see what they’ll do now.


(D Bryce Mitton) #11

I have the same problem - I have been in touch with support and they have tried to help, but no joy.
I have a macbook pro with El Capitan installed. I have the latest version of RW7 upgraded from RW 5.
Has anyone found a solution for this problem?