Are we considering RW 7.5.5 "it"?


(William VILLERS) #1

Given that 7.5.5 seems to have been the latest for quite some time, is it to be considered the last release of 7? I’m asking because we still can’t publish the entirety of our website directly from RW and have to use filezilla to push our changes…

Is there any 8 beta coming soon?


(Nigel) #2

Hi

I have 7.5.5 and can publish fine. The only time I have had any issues with publishing with any RW versions it has been the fault of the router and has been fixed by a restart of the mac and a reset of the router.
Now I have a better router I have had no problems at all.

Nigel


(Doug Bennett) #3

Not sure what publishing issues you’re having, but I wouldn’t think a RW 8 version would solve it for you.
In fact usually a “major release” with any software creates more problems out of the gate.
Perhaps giving more details on the problems you’ve been having?


(William VILLERS) #4

Thanks for the replies, guys.

@teefers major releases are not always catastrophic, RW7 was a vast improvement over any 6.x with very few issues for instance… As I see 7.5.5 being the last of the 7s, I was wondering if 8 was coming out in beta. If the problem persist, then we can raise the issue for 8 before it’s gold release…

@Nigel The problem has been highlighted multiple times over the months in this forum, from myself and others. Basically, RW “chokes” at publishing the last file of the batch, regardless of its size or type… The original answer was “blame your ISP”, but this wasn’t the case as FileZilla or other ftp options had no issues… A few suggestions were made as far as publishing settings, to no avail… It is a recognized problem…


(Robert Ziebol 🖖🏼) #5

As far as I know, the developers have not even got their hands on a release yet. So no public beta any time soon. Keep bugging support for help, maybe they can figure out something.


(Peter Rood) #6

I have had similar FTP issues from within RW. It will upload 500 files and then die. Or it will upload 999 of 1000 files and die. Other times it is perfect. for larger sites I have to sometimes publish locally and sync with Transmit.


(LJ) #7

There’s nothing fundamentally wrong with 7.5.5 publishing. We have around 70 RW sites and they all publish fine in 7.5.5 so the issue probably lies with an out of date plug in or some file corruption - that will likely only be exacerbated in a new release. If I were you I’d take a good look at your plug-ins and check they are a) up to date and b) still compatible at all. It only takes one plug-in that is no longer supported to cause serious problems.


(Doug Bennett) #8

Don’t know what version of 7 you started with, but the early 7.0, 7.02, 7.1.6, right through 7.4. All had issues, especially in the publishing area.
Just some sample post:


Since as @zeebe indicated developers don’t have an early alpha yet, I wouldn’t expect a rw8 anytime soon.
If anyone is having issues with the current release, you shouldn’t wait for an upgrade. The problem you’re having should be addressed with the current version.
RW7 had a complete rewrite of the publishing engine so that I wouldn’t expect another significant change in that area with RW8.
https://rapidweavercommunity.com/tutorials/new-features-in-rapidweaver-7/new-publishing-engine


(William VILLERS) #9

Thanks again for the response. We started using RW in 2011 and have been moving along every release since then, including every point release. We didn’t have many issues, once in a while we were hit by a little publishing snag, but this got solved at the next point release… This one is staying, and RW seems to have stagnated at 7.5.5 for quite some time now…

This particular issue at hand relates to publishing the last file of whatever is being published. Somehow, the last file to be published always failed (and I am not an isolated case). It was a problem in 7.4, was fixed in a 7.4.x release, then came back in 7.5.x and is still there…


(William VILLERS) #10

No issue with plugins, everything is up to date… I even did a “save as” to see if the file was corrupt (good suggestion, thanks, I always forget about file corruption :slight_smile: ), to no avail… The last file of the upload always end up in an error “Timeout was reached”… I don’t get timeouts with FileZilla…


(Robert Ziebol 🖖🏼) #11

Have you informed support of this?? Do you remember which version of 7.4.x fixed it?? Maybe they could look at those builds and see if they changed anything…


(David) #12

If everything else was working for you in 7.4.x, you could temporarily go back to using that version.


(LJ) #13

How big is your site?


(LJ) #14

I’d be interested to see a list of your plug ins (not individual stacks)


(Doug Bennett) #15

I would let Realmac support know. I don’t know for sure, but I think this might be the last release for version 7, at least unless something comes up that requires an emergency fix. Just my guess that any further effort is going towards RW8, but that could be quite a while.
The publishing engine within RapidWeaver always seems to be a bit temperamental, but for most folks that use it, it usually gets the job done.


(Aaron Marquez) #16

Hi @wvillers,

Can you send a screenshot of the error message and your support logs to us: support[at]realmacsoftware.com

RapidWeaver has a built-in FTP engine, essentially what the publishing engine is. RapidWeaver exports the document into server-friendly files / language, then uploads as a regular FTP client. A bad plugin, as mentioned, could cause issues with the export of the site. Every host has different settings they prefer, and the key is configuring RapidWeaver to match those preferred settings.


(system) #17

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.