Publishing Issue RW7


(Mark Todd) #1

I’m having an issue where I can’t seem to publish large files to my FTP. What I can do is publish a few pages at a time, but when I try to re-publish all the site files, or even publish the changes where most of the pages need to be published, RW just seems to stop at “Exporting (name of page)”.

It does this on all of the RW7 files I have converted. But, like I said, I can export pages individually.


Out of Application Memory - Publishing in RW 7
(Scott) #2

I have the same issue for 6 weeks and am getting no support other than to try yet another Beta version. Anyone else having this export problem?


(Scott) #3

I have sent Dan the Founder my project files that are exhibiting the same problem that you explain. Will report back with any info.


(Gary Balfour) #4

I am also having problems publishing with publishing. I have tried to publish directly (and have tested the connection). I have also tried to export the files to my drive and would have used FTP to upload them. But half way through I get an error message. The site was upgraded to RW7. I am using an iMac with plenty of memory and the latest OX.
Below is a screen shots of the site publishing at the point it fails. The site is www.garywalker.net.


(LJ) #5

Have you got publishing set to Extended Passive? This is default for new RW7 projects but not necessarily for those upgraded from RW6.


(Gary Balfour) #6

Yes, it is set to the default of Extended Passive. I have not tried to change that one.


(Jason Bostick) #7

The other one to play around with is the number of connections (from 1 to 6). I generally havent had publishing/exporting problems but once or twice, I’ve gone into my Cpanel and into the ‘ftp session control’ and quit any open sessions, then retried and it’s helped.


(LJ) #8

Maybe try the others - I’m no expert but believe it depends on your hosting environment. for me, all older RW6 projects that I have upgraded and forgotten to change to Extended Passive have exactly your symptoms. With other hosts it may be the other way around?

Another issue I had with one very large site was using the “Minify CSS and Javascript” setting. Turning this on made publishing grind to a halt. When I turned it off all worked fine again. If you’re not aware, it is in the Settings (left) > General > Advanced


(Gary Balfour) #9

I think the problem must be with the file. It starts to upload the site fine but when it gets to around 240 of 680, it fails. The same thing happens when I try to export the site to my hard drive. I did just export a different site and there was no problem. I will look for an earlier copy and see if that is okay.

Thanks to all that offered help.


(LJ) #10

do try un-checking the minify css & Javascript option if it is on - certainly caused a problem for me with one large site.


(Scott) #11

Thanks for that idea, although my site hung during publish it was the first time that it made through the Export process for the whole project. Will experiment further.


(Scott) #12

after a bit of experimenting I have a work around for my site. I have un checked minify css and javascript as @manofdogz kindly suggested and that helped. But I could not publish my whole project directly and could only do sections at a time. I tired publish to a local folder and upload via FTP and this is working and the smart publish function is tracking changes correctly with the blue dot on changes pages.

www.insideoutskiing.com


(Gary Balfour) #13

It seems my publishing issues are back when using RW7. If I try to publish directly by FTP, it gets halfway through the upload and stops giving a message that there was an error. If I try to export to my hard drive so that I can upload by FTP myself, it also stops and gives an error halfway through the process.

I am desperate!
Please help


(Isaiah Carew) #14

There are many possible errors that can halt an export – and it’s probably impossible to guess which one is the one that you’re suffering from. It would be helpful to have some more details:

  • what did the error message say?
  • what page does the export fail on?
  • can you export that page by itself?

and the basics of your setup are always helpful in any sort of issue:

  • what version of macOS are you using?
  • what version of RapidWeaver are you using?
  • are you using a plugin (like Stacks)?
  • what version of Stacks are you using?

If it’s a Stacks error, then it’s probably best to send the project, along with any plugins and themes to YourHead Software support: http://yourhead.com/support

Otherwise it’s probably best to send the project to RealMac support.


(David Schmaltz) #15

After spending eight hours or so trying, so-far unsuccessfully, to FTP an update to my PureSchmaltz Blog (PureSchmaltz.com), I’m moved to wonder how I might determine the parameters the RW FTP loader might be (just must be) adding to the Parameters I enter on the FTP form. It appears the loader duplicates some of the entered data when constructing the path name to be updated on the server. Is there any place where I might confirm my suspicion? An export file header? A Console entry? Where? I send an update one place and it ends up in a wholly different place on the server and I can’t quite crack the algorithm it seems to employ to ship my successful updates to places no browser querying the web address could ever find. I was able to copy and move my latest update to the expected location from the unexpected one, using server commands, but this seems an unworkable day to day solution. FTP worked on some release prior to 7.5.5. Not at all now. I will appreciate any help. Thank you.


(nigel) #16

HI

I have a problem with Rapidweaver 7.5.5 - I am trying to publish my site to Siteground . I fill in the details as requested in the publising form. When I hit the test button - I get the following message

Connection Test Successful
The Credentials entered appear to be valid. Be sure to test again if you change any settings.

I then try to publish my site to siteground and approx two thirds of the way through uploading , I get the following message

Couldn’t upload to your FTP server

and either

URL using bad/illegal format or missing URL. URL ftp://uk6.siteground.eu

or

Operation was aborted by an application callback. URL: ftp://uk6.siteground.eu

I have also tried entering the URL as uk6.siteground.eu and have the same issue. I can however upload by exporting my site to my local drive then using ftp software - transmit 2 to upload. Siteground assure me that there are no problems at their end. Can anyone help me solve this frustrating issue ?


(Isaiah Carew) #17

@nigeltownsend

  1. This issue is likely to be unrelated to the original post – so it should probably be in it’s own thread.

  2. I always recommend trying SFTP. It is a much more modern transfer protocol and nearly every host supports it – in fact, if you host does not it might be a good idea to change hosts. :wink:

  3. If switching pubishing methods does not work around the issue, I would recommend contacting RW support to see if there is some other logging into they can gather about your issue since everything else seems in order – perhaps they can gather a bit more info from some RW logs and help you solve the mystery.


(nigel) #18

Taaa Isaiah

  1. Not quite sure how to create it’s own thread - sorry I’m a bit of a novice, can you advise?

  2. I will ask Siteground if they support SFTP - I think they do

  3. Will do if switching transfer protocol doesn’t work


(Isaiah Carew) #19

@nigeltownsend - i just meant you probably shouldn’t post your question at the end of someone else’s question here on the forum – unless posting them together is helpful. but don’t worry about it, just something for next time. :wink:

how to: instead of clicking Reply you click the Home button then click New Topic to start your own brand new post/topic/thread/whatever-it’s-called :stuck_out_tongue:


(Brian LaPan) #20