At the end of my Tether with RW7 publishing issues


(Bernard O'Sullivan) #1

Hi There

Is anyone else having problems with sites not uploading or exporting to folders under RW7?

From the moment I moved over from RW6 to RW7.4 I have been having nothing but problems especially relating to failure to export to folder and the pre-view pane not working.

Initially these were restricted to sites under construction using Stacks which I have contacted you about previously. Those issues seem to have been resolved by updating plug-ins and updating to V7.0.4
, those issues seem to have been resolved.

However recently in-between V7.0.1 and V7.0.4 other ‘new’ issues have surfaced.

My own insideoutphoto site will simply neither upload or export without an ‘Oops something went wrong message’ I must stress at this stage that the FTP settings have not changed since RW3 and are as recommended and correct, I have been using RW for many years and find it frustrating that I am having so many problems since buying the new version, especially as I was looking forward to using some of the new features in RW7 such as ‘Health Check’

The persistent issue is a failure to upload or export to folder. I have supplied a list below of all that I have tried to resolve the problem.

1: Checked FTP, this is correct and works when uploading other clients sites.
2: Checked all plug-ins and Themes for updates.
3: Removed SEO RX, Rapidbot.
4: Tried export-to-folder my site using stacks.
5: Tried export-to-folder my site 2 different Themes. Both failed!
6: Tried uploading from a different Mac in a different location.
7: Tried to cancel a ‘frozen’ upload and publish again, got error message sayin ‘Could not publish as an export is already underway’
8: Tried to upload my insideoutphoto site by reverting to RW6 THIS WORKED!

Important: I have 3 other sites 1 already on-line, and 2 under construction.

The on-line site uses and older non-responsive Theme ‘Lime’ and uploads perfectly.
I am yet to attempt to publish the 2 under construction sites, however both have exported to folder without any issues, Both sites use the same Theme and plug-ins as my own site.

Following an exchange of emails with a RW support person based in Arizona USA I was informed that V7.1 was about to be released and this might resolve the issues. As requested, 14 days ago I sent a insideoutphoto project file with plugins etc via ‘wetransfer’.

This ‘wetransfer’ file was downloaded on the 19th of July but have had no response as yet.

I have gone through the plugins, themes etc very carefully and as far as I can ascertain all are up to date, I have not been able to upload/update my insideoutphoto site now for 3-4 weeks, which may now be affecting my Google ratings.

System info below.
RW7.0.4
Feather Theme
Active plugins for my site include, Rapidweaver, SEO RX, Rapidbot.

As I mentioned my other sites seem to export or upload without problems, the only difference I can think of is that the number of pages on my http://www.insideoutphoto.co.uk/ site is greater than the other sites mentioned, although once again this has not changed for the past 7 months and has worked fine!

  • 59 pages including site map SEO RX and Rapidbot

I would be grateful if you would briefly acknowledge the safe receipt of this email.

Yours sincerely


(Tron) #2

I found that in one of the updates the default went from Extended Passive to Passive, even though Extended Passive still says default. Everything I had in RW7 stopped uploading instantly. Reselected Extended Passive and all was good in the world again.

The same thing has happened for several people I know and this has fixed it for us.


(Mark Todd) #3

I’m still having issues with large site publishing. And NOW a new problem has begun to surface: when I publish the files page by page (that seems to work), the sites are loading on the browser (Safari, Firefox, Chrome … doesn’t seem to matter) VERY SLOWLY … sometimes taking 15-20 minutes. Also, when I duplicate pages and change the data on them, they publish with the old data. All in all, there seems to be some very odd things going on with this update.


(Bernard O'Sullivan) #4

Firstly many thanks for the reply!

I have tried ‘Extended Passive’ as well as all others, but still no success. How did you manage to publish 1 page at a time and will that still work if all my pages are showing changes!


(Bernard O'Sullivan) #5

Hi There Firstly many thanks for your interest and help on this.

Just for the record I had and have again tried switching the publishing settings, but to no avail!


#6

Use a 3rd party FTP client like Yummy or Transmit. I export to a local folder on my computer using RW and then use the synchronise feature in Yummy, so that the server is synched with my exported folder. This works reliably and also cleans up unwanted content on the server, such as deleted pages. It’s just not worth the stress and lost time constantly battling with RW FTP issues.

EDIT: For sitemaps I disable this is RW because I gather it only includes pages shown in the main menu. Instead I use Integrity Plus that works well.


(Simon Maddox) #7

Hi @rapidbernardos58

If you can share your project and FTP details with support@realmacsoftware.com or directly with me on this forum, I can take a look at what’s going on for you.

Cheers,

Simon


(LJ) #8

Two possible solutions: one is the Extended Passive publishing setting - which you say is selected.

The second is that with some sites (larger ones in particular) “Minify CSS and Javascript” causes publishing to hang. I’ve not had a chance to test further but switching this option off has solved the problem on 2 large sites for me. If you are not familiar, it is in Settings > General > Advanced. Probably not set by default but if you switched it on, try switching it off.

The setting is by no means essential - should speed up your site a little and maybe get you an extra brownie point for SEO


(Bernard O'Sullivan) #9

Hi There

Firstly many thanks for your help/interest!

I tried what you suggested and interestingly the upload process seemed to get much further, before hanging up, it froze while uploading ‘classic-map-red.png’ but i am assuming that file isn’t likely to be the cause as it is used in other uploads.


(Bernard O'Sullivan) #10

Also, oddly I have only just noticed that the ‘Save As’ option has gone from RW7.0.4 just ‘Save’ or ‘Rename’ strange!


(Ric) #11

@rapidbernardos58

I’m running 7.0.4 and the ‘Save as’ option is most definitely there.


(Bernard O'Sullivan) #12

The ‘Save as’ option has vanished from my drop down, bizarre, I wish I had stayed with RW6 now!


(LJ) #13

I’m running 7.0.4 under El Capitan 10.11.6 and “save as” is definitely there. Double check it is 7.0.4 - the App logo doesn’t usually make it clear. Then maybe close everything and restart your Mac


(Jonathan Spencer) #14

Press the Option Key to get the Save As… menu option.


(Brian Vince) #15

I had almost the exact symptoms you describe when 7 first came out, particularly with a couple of large sites. I have turned on extended passive and turned off the “minify” setting. This seemed to fix it for me after release 7.0.4. I noticed that the publishing got further through by closing and restarting RW immediately before publishing … also I found that using the new feature to allow publishing selected blocks of pages I was able to get my site running. It seemed that RW would be ok for about one quarter of my files then fail. so I selected the files in five chunks and restarted RW in between each chunk … this worked for me to get published.


(Bernard O'Sullivan) #16

Hi There many thanks for than info, I will give it a go and let you know if it works. I am more than a little bit peeved that I have lost so many hours trying to sort a problem out caused by my spending money on new improved software. Not good at all!


(Scott) #17

yet more cases of people not getting support and the same answer of it will all be sorted in the next release…


(Bernard O'Sullivan) #18

Hi There

Can you tell me how you go about publishing in ‘chunks’ at this stage all my pages are showing as having been updated!


(Bernard O'Sullivan) #19

I know it doesn’t make sense to say that ‘Save as’ isn’t there but take a look at the screen grab I have attached.
Note ‘Duplicate’ under Save with what looks like a ‘Save-As’ keyboard short-cut, I haven’t tried this but, has anyone else seen this drop down change!


(Brian Vince) #20

Hi again. 1st select a page, then holding shift select a page further down … this should highlight your selection. Then right click … you should get an option to publish selected pages.