Armadillo causing problems


(Dan Thomas) #1

I’ve had to totally re-upload a site that has been working fine for the last couple of years.

The strange thing is that it looks fine within RapidWeaver, or previewed in a browser directly from RapidWeaver, but once uploaded it is now visually broken. I have contacted Will Woodgate (who built the theme for me) and he has spotted a potential Armadillo error —the armadilloFunctions.js file: “fancybox is not a function” (whatever that means!).

Does anyone have any ideas as to what might be causing this problem / know of a fix?

The web site is live here: http://www.henrychancellor.com/

It should look like this: https://cl.ly/0C0J192W0x1r
but looks like this: https://cl.ly/33271s0S1V0O

and here is the error: https://cl.ly/29291F1C0S3x


(Rob Beattie) #2

Fancybox is a lightbox - see here. So maybe there’s a conflict with some other JQuery being used on the page?

Are you using Armadillo’s built-in lightbox for images, perhaps?

Rob


(Dan Thomas) #3

Thanks for the reply — not aware of the Lightbox function in Armadillo (in fact I can’t find any reference to it in the Stack’s preferences). I have deleted the Armadillo stacks from the page and the site looks fine…


(klaatu) #4

@danchd
You can read about the lightbox in Armadillo here:
http://docs.nimblehost.com/armadillo#using-armadillo-1425

Sounds like a javascript function is being called out of scope, for whatever reason. I seem to recall a post sometime in the past from Nimblehost about this error, but I could be mistaken.

UPDATE
Found it here:


(Dan Thomas) #5

Removing Armadillo from a page fixes the broken theme. I thought I should perhaps re-install Armadillo / replace the Armadillo stacks in each page. Still no joy, or would I have to restart my machine after installing?

Or, as I previously had no problems, should I perhaps install an older version of Armadillo?


(Doug Bennett) #6

Did you try the solution in the post above:

jQuery.noConflict(true);

(Dan Thomas) #7

I have added the code snippet and uploaded the whole site, with the pages with Armadillo elements restored, to

http://www.henrychancellor.com/testing-armadillo/

…and the problem persists. The first three pages; home, about, and news use Armadillo and are broken. The other pages still look fine…

http://www.henrychancellor.com is be working OK now I’ve deleted all Armadillo bits and pieces…


(Dan Thomas) #8

Another (hopefully) related problem,

I have a some bespoke navigation graphics that I created as a separate page that is imported into other pages using PlusKit @import function (again, been working for years, suddenly errors).

The page can be viewed working here:
http://www.henrychancellor.com/books/tom/scat-nav/

It should (and does) import onto other pages like:
http://www.henrychancellor.com/books/tom/the-forgotten-echo/ and
http://www.henrychancellor.com/books/tom/scatterhorn-background/

But as you can see, the shelves are empty of their book links. These links have HoverBox rollovers that disappear when imported using @import.

I have added the jQuery.noConflict(true); snippet but no joy.

Might this be a RapidWeaver issue, rather than a PlugIn issue as it appears to be affecting various unrelated JavaScripts that were all working fine for years, but have suddenly become broken …


(Dan Thomas) #9

Well I’ve fixed that second problem — by adding the latest FancyBox code to the header code of the theme from here: http://fancyapps.com/fancybox/3/

Unfortunately this doesn’t solve the Armadillo problem. Tried restoring its stacks but no joy.


(system) #10

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.