Armadillo issue resolved


(Gnosis Media) #1

Is anyone else out there in Rapidweaver land experiencing the same persistent massive issues with Armadillo that I am such as:

  • Pictures disappearing
  • Categories and Tags won’t save

If so, and you have a work around, I’d love to know.

Nimblehost hasn’t responded to supports tickets.

Thx!


(Dick Sijtsma) #2

I do know Armadillo. I sometimes run into minor problems. Most of the time it has to do with the hosting, or with the settings within Armadillo. This might be the case this time too.
Do you have a url?


(Peter Danckwerts) #3

Never had any problems with Armadillo (other than when I haven’t followed the instructions).


(Brian LaPan) #4

Hang tight, everybody. Johnathon’s just a bit tied up at the moment. He’ll be looking into this (and other support issues) shortly - (from his team)


(Gnosis Media) #5

Basically I’ve discovered that if you use Armadillo in a dev directory and populate it with any media content, Armadillo retains the dev reference URLS even when moved to the root directory. It’s kinda sloppy but the best work around is to leave an rw_common folder in your dev director and let Armadillo populate a new one for future posts in the same folder in the root directory.


(Jonathan Head) #6

We do need some time to respond. It had barely been a day since you sent in the request and then posted on the forums here. :wink:

This isn’t quite correct; to clarify for those viewing this thread at a later date, Armadillo creates absolute URLs to images when you add them to content - just like most CMSes. So if you create the site in one directory (during development, for example), then move it later to another directory and delete the “old” files, then it goes without saying that the URLs to the images will be incorrect since the location of the images has changed and the original files are gone.


(Dick Sijtsma) #7

@gnosismedia : you can develop a site with Armadillo in the main domain too. I created a new site immediately on the correct domain. To achieve this i did the following

  • i created a temporary home page
  • no navigation / menu on this page
  • i created all my pages in the project
  • i hide them in navigation too
  • i added this metatag to every page (temporarily) <meta name="robots" content="noindex,nofollow"/> This prevents Google showing the results in the SERP (https://yoast.com/prevent-site-being-indexed/)
  • i sent all the ‘secret’ urls to the customer, so he could judge the progress of the new site
  • when all was all-right, i only had to remove the temporary home page, uncheck the ‘hide navigation’ option and removing the metatag.

Big advantage was that i had all the correct urls for the images in Armadillo.

But i’m sure there are other ways to do this too.