Armadillo Setup Problem?


(Andrew Tyzack) #1

I’ve setup Armadillo for use on my website, published successfully (I think?) but having problems getting past the setup. I’m getting as far as Step3: choice of time zone and language, but when I click Finish, Armadillo just tells me that it “can’t connect to the database with those settings”. I have a MySQL database setup and have the database name etc. Armadillo aren’t letting me know which information is wrong, which is leaving me to guess. I suspect it’s the database hostname that I’m entering wrong, but have no idea if this is the case? My database host clearly labels the host name in my control panel, as it does all the other necessary information.

Thanks for any help,

Andrew


(Jonathan Head) #2

Hi Andrew,

There a few common causes for this type of error:

  • The database details are incorrect.
  • The database user is not assigned to the database you want to use. Some hosting companies set this up for you, but others do not. In short, the db user must be given access to the database, with full permission to make changes. Unfortunately, this isn’t something Armadillo can do for you.
  • The database password contains certain special characters that have special meaning in MySQL. If you need to use special characters in a database password I’d suggest sticking with ! and @ - in my testing they cause the least amount of issues.

Hope this helps.


(Andrew Tyzack) #3

Thanks for the advice. I’ve since gained access, not sure how exactly? I’m still using the same details? I think it’s possible that as I was copying and pasting the database details directly from the RW info pane, I was picking up some space and Armadillo was counting this as PW characters? But I’m not sure?

I’ll let you know if I have anymore problems,

Andrew


(Andrew Tyzack) #4

It might also be because I re-published the site a couple of times? Could there have been an issue with the publishing?

Just had another check and it does look like as I highlight the database host name in the RW info pane for copying, that there is about 4 or 5 spaces attached to the end - could that be why I wasn’t getting access?

I have actually just deleted the spaces…might make the difference?


(Jonathan Head) #5

Yes, additional spaces would be treated as part of the valid, correct database host, so they’ll need to be removed.


(Threetooltrader) #6

I’m having this same exact issue. I have no special characters in my password, just upper and lower case letters and numbers. I’m not sure if I have given my DB user full permissions. I have give the user folder access to both the stacks and armadillo folder. Neither worked, I tried both 775 and 777 permissions and neither worked. When I refresh after changing the permission I get a 500 error. Machighway is hosting the site. Not sure were to go from here. Any help or tips would be greatly appreciated. Merry Christmas to Everyone.


(Jonathan Head) #7

I would check this first, as it will prevent Armadillo from connecting and setting up the database. Unfortunately, this is not something Armadillo can fix for you, and the interface to make the necessary user changes varies with each hosting provider, so it’s difficult to provide generalized instructions.


(Tom Coyne) #8

Just purchases Armadillo and wasted an entire afternoon trying to get it to work with Network Solutions. I’ve double checked that both NetSol and Armadillo have the same information, but I keep getting the “can’t connect” to the DB error. This is beyond frustrating. Any suggestions, before I start slagging the poor documentation and lack of user support?


(Rob Beattie) #9

Have you filed a support query with @nimblehost? That’ll be the best way forward.


(Jonathan Head) #10

Hi @TC415,

A couple of suggestions:

  • Has the database user been assigned to the database Armadillo is supposed to use? This is a separate issue from the credentials being correct; the db user must specifically be assigned to the database.

  • Does the database user have sufficient privileges to access and make changes to the database? This is, again, separate from the credentials being accurate (and different again from the factor listed above).

To clarify, even if the db user has the correct credentials, they cannot connect if they are not assigned to the database from the hosting control panel. Likewise, even if the credentials are correct and they are assigned to the database, they will not be able to connect if they do not have sufficient privileges to access and make changes to the database.

Some hosting companies manage this stuff for you, while others do not. Could you clarify that you have checked both of the above points (separate from the login credentials being accurate or not)?