Armadillo: Slim application error #2 on several of my websites

Well, I’m glad you got it working.

I’m going to get a quick test up with Armadillo at my hosting company (DreamHost) and see if I hit the same thing with PHP 7.4.

I just changed VPS plans, so they moved my stuff to a new server. I’m experiencing some minor issues publishing to a new test domain. Should get it worked out soon.

I don’t know if Armadillo will work with PHP 8, that’s a big change from 7. x and my guess is there will need to be some changes to Aramdillo to support that, but Jonathan (@nimblehost) will need to address this.

Hi Franz (@Franz),

I just completed a test with Armadillo using PHP Version 7.4.14, and had no problems.

So my guess would be that something at your hosting company’s settings in the php.ini differs other than the php version when you switched from 7.3 to 7.4.

Joe (@joeworkman) has a free stack called Server Info, that you can use to get most of the common values that are being set. Just pop it on a test page and will list a lot of values.

I’d probably try it with a test page and change the PHP version and try it again. You’d need to compare the values manually. I can tell you that on my DreamHost account, the value for open_basedir set to no value.

Jonathan (@nimblehost) might give you more information.

Armadillo runs fine with PHP 7.4 based on my testing (and as @teefers has experienced), but (needless to say) there are many different possible configurations and I’ve not tested Armadillo against all (or even most) of them. Good catch regarding the media folder path name missing a forward slash “/” - I actually had made a note to mention this and you caught it before I had a chance to do so. :slight_smile:

Also, many thanks to @teefers for your help!

I still have 2 questions:

  1. How can I change the media folder path name? And which php.ini file is it that needs to be tweaked? This is kind of mysterious to me…
    Thanks to Dougs counsel I downloaded the Server Info and installed it on a test site. It shows a number of php.ini files. Which one do I need to open and how do I do that?

  1. What can I do to make the installation of a test Armadillo databank for a blog on my test website work? I tried it several times but I get the error message “…armadillo_post’ doesn’t exist” What have I missed again?

Sorry for bothering so long with these issues.

That would probably be a question for your hosting company or might be in their knowledge base area.

You see you might and probably don’t not have access to the “main” PHP.ini file if you are in a shared hosting environment.

If you are running in an unmanaged VPS or a dedicated server then you could make changes to anything.

PHP supports Runtime Configuration (RC) files. Where they are and what access you have can vary from hosting company.

Hi Franz,

How can I change the media folder path name?

You shouldn’t need to. Most of the time Armadillo uses relative paths to the media folder, and these work as expected as the directory separator is included in the path. In the few cases an absolute URL is used, Armadillo uses the PHP predefined constant DIRECTORY_SEPARATOR - the only way I can currently imagine for this to happen (missing the forward slash between “armadillo” and “media”) is if that predefined PHP constant isn’t available in the PHP configuration on your hosting account - which would be the first time I’ve seen that, well, ever. I’d suggest contacting the hosting company to ask if DIRECTORY_SEPARATOR is available for use to PHP apps under your hosting account.

but I get the error message “…armadillo_post’ doesn’t exist” What have I missed again?

This means the database hasn’t been setup for Armadillo yet. You’ll need to go through online setup in order to do so. You can force this to happen by removing/renaming the config.php file located at rw_common/plugins/stacks/armadillo/core

Hope this helps.

1 Like

Dear Jonathan,
thank you very much for your reply.

  1. I will contact concerning this DIRECTORY_SEPARATOR.
  2. I removed the config.php file, yet it was not working. I had to totally delete the old database and create a new one with new login etc. NOW it has worked! Great!
    Thanks again for your support!

Update September 1:

This is the response from in translation:
… the constant DIRECTORY_SEPARATOR is defined as “/”
(die Konstante DIRECTORY_SEPARATOR ist definiert mit dem Wert “/”.)

It seems mysterious to me how the separator can be missing in this case.

You should switch to Chillidog Hosting. I have used them for years and Armadillo / RW works fine.

I setup a test Armadillo site at DreamHost in about 5 minutes. Running great, even ran a quick test using php 8.0.

Been using DreamHost for years without any issues. The support (24/7) is incredible. You can chat online, cut a ticket or have them call you back. I’ve always had my tickets answered within 20 minutes, usually less. No waiting for someone to get back to you while your site is down.

The staff are all truly knowledgeable, and they have one of the best knowledge bases out there. I’ve used them for about every kind of website you can think of.

Can’t say enough good things about them. Here’s a referral link if you want.


Thanks, @teefers and @parker, but switching to another hosting provider after one year is not what I want to do. Besides the difference in cost. I am paying for 500 GB SSD space something like 65 EUR per year since I got a deal with 50% rebate.

Since the DIRECTORY SEPARATOR is in place on the hoster’s side, I still have a hunch that something in Armadillo must be producing the link with the missing separator. But I am not a specialist, I can be wrong.

I tested again today, only PHP 7.3 works with the Armadillo blog, 7.4 and 8.0 don’t. If I can stay with 7.3 the next 5+ years, I can live with that…

Thanks, gentlemen, for your kind help, anyway! I appreciate it.

Franz @Franz ,

Not a good idea

7.3 no active support - ended 8 months ago. Security Support ends in 3 months (6 Dec 2021).
PHP: Supported Versions

If you really want to check to see if the DIRECTORY_SEPARATOR is what changed with your hosting configuration between PHP 7.3, 7.4, 8.0, you can simply display it.

setup a test page and add the following to an HTML stack:

echo “directory SEPARATOR is :’”, DIRECTORY_SEPARATOR, “‘“;

Make sure you set the test page up as an index.php and check it when you change to a different php version.
it should return a display like this:

directory SEPARATOR is :’/’

You could set this up on the same page as the server info stack. just mark it as not in navigation, no index no follow and the the page folder something like php-debug

As for what php.ini file you might have access to the one listed in you etc/
directory. It’s listed above under "Loaded Configuration File`. The other ones you I doubt you would have access too.

That simple test under the different php versions would prove or not that the separator is the issue. My gut tells me it’s something else in the configuration of your hosts between the php versions. Mainly because a lot of folks are running Armadillo on 7.4 and aren’t having any issues. As I said earlier I’m able to run it with 8.0.

If you could get access to look at the /usr/local/php73/etc , /usr/local/php74/etc and the /usr/local/php80/etc` you might get to the bottom of it.

DreamHost has unlimited SSD plains starting at $2.95 a month ($36 or about 31 EUR a year) to start. I don’t care if you switch host, but you really need to address being able to run current php versions. You have about 3 months and your site might become at risk (no more security updates).


Hi Doug,
I appreciate your feedback and help.
I have published the content above on a new html stack but I am getting an error message:

Parse error : syntax error, unexpected ‘SEPARATOR’ (T_STRING), expecting ‘;’ or ‘,’ in /private/var/folders/p5/zx5hynsx1959tqvw5zwpdf900000gn/T/com.realmacsoftware.rapidweaver8/RapidWeaver/37138/document-0x7fdc426d6f50/RWDocumentPagePreview/php-debug/index.php on line 2

My iMac has added the double asterix when I pasted the above in here. Any advice how to proceed? Thanks in advance!

echo "directory SEPARATOR is :'", DIRECTORY_SEPARATOR, "'";

Looks like the forum might have change the code to curly quotes.


I just copied and pasted the code on this post (not above) and it works.

Thanks, it is working now:

When using php 7.3 it responds with the correcht message (’/’).
When using php 7.4 the same
When using php 8.0 on the server info page it still shows the php 7.4 version, not the 8.0 (but on netcup’s panel it shows php 8.0)

I would be happy if 7.4 would be working again with the blog. But it doesn’t, I checked again.
I am at my wits end.

I didn’t think that was the issue. When I run 8.0 server information shows 8.0. Server information is taken from PHP directly, so if it’s showing 7.4, I would bet money that’s what’s running on the server then. Don’t care what any control panel says, PHP itself is returning the version number.

I guess that it’s something else in the php.ini configurations between the two versions. 7.3 and 7.4 aren’t that different. It’s really just a minor maintenance release.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.