Back to my Foundation Button Group weird blue thing!


(Gary Davis) #1

RW 6, Foundation, Button Group Stack

I posted about this a while back. Have a weird thing happening with the buttons in a green two-button Foundation button group turning to blue. But could not nail down exactly when it did / did not happen. Now have, I think. Please check out this short YouTube video:

This is in Safari. I also tried it in Chrome. Doesn’t happen at all in Chrome.

I have deleted the original button group I had there and replaced it with the same thing a little while back, to make sure it was after the latest updates to everything. Acted the same as it did before. It’s not a cache issue; I made sure to refresh pages often and have cleared my whole browser cache more than once over the past few days. Not a big deal, clearly. But I’d like to know what it is and be able to fix it, anyway. Thanks!


(Peter Danckwerts) #2

The obvious answer would be that you somehow have the visited state of the button set to blue, but I don’t know how that would happen – it isn’t usually set in the Foundation stacks.


(Gary Davis) #3

No, there is not that setting in this stack. And if there were, and the visited state were set to blue, then it should stay that way once visited. This just flicks into and out of blue and only under certain conditions, as you see in the video. It’s not much of a problem but I find it interesting and would like to know what causes it.


(Robert Ziebol 🖖🏼) #4

This really has to be an issue somewhere on your end, I have 3 computers I have tried it on here, and this video from my MacBook Pro shows, it never happens to me once. Do you have any extensions installed on Safari that might be causing this. It is definitely on your end.

Video Link


(Gary Davis) #5

Well, that’s good if it is. Not a real problem, anyway. Just a little oddity. Extensions on my Safari are Instafari, Readability, Feedly, 1Password & AdBlock.


(Robert Ziebol 🖖🏼) #6

Put money it is adblock, that is the WORST extension out there. Turn that off and see what happens.


(Gary Davis) #7

I disabled AdBlock, quit and restarted Safari and the page did the same thing. The interesting thing is – as you see in the video I made – if you use the button, then go back to the home page using the < arrow at the top of the page, then pass over the button with the cursor, it turns blue. Back to green as soon as you click anywhere on the page. But if you go back to the home page using “Home” in the menu, then no blue button when you get back.

One other note: blue was originally the primary elements color in the Site Styles stack for that page. I changed it to green. Same thing for all the other pages, except that the other pages have “Site Styles (Legacy)” while Home has just “Site Styles”. So I must have replaced the old stack on the Home page for a new one after the Stacks 3 updates, maybe to try to fix the green / blue thing. Tried to make it happen on another page where a green button takes you to a new page but it doesn’t happen. Only with this button group on the home page.


(Robert Ziebol 🖖🏼) #8

Sorry to say, it is not a Foundation or Site Styles issue, if it was, it would be happening on everyone’s machine and it is not. Do you have any other machine to try this on?? Try turning off ALL extensions and see what happens, then slowly add them until it happens again. Also, what version of Safari do you have?


(Gary Davis) #9

Safari 8.0.8. I understand. I don’t see it on my Chrome browser, either. I am not at all concerned about it. Of no consequence. But interesting. As you say, possibly just on my machine for reasons that may never be known. But – if you ever see something like this in the future, you will remember this and go, “Hmmmm”. Thanks.


(Bruce Kieffer) #10

Give us the link so we can see if it happens on our computers.


(Gary Davis) #11

http://televisionadvertising.com Home page. The green double button set that says “Lawyers” on one side and “Denture Clinics” on the other. But I think you would have to watch my little video to see what to do.


(Peter Danckwerts) #12

Doesn’t happen on my Safari 8.0.8.


(Bruce Kieffer) #13

Does happen on my Safari 8.0.8.


(Robert Ziebol 🖖🏼) #14

@bruce would love to see a video of it. Use Quicktime and do a screen recording. Also, turn off all extensions on safari if you have any on.


(Ivaylo Hristoforov) #15

@zeebe I just try it and the buttons turn blue. I must say that I’m on OS X El Capitan and Safari 9 (the extensions are disabled). Here is the video to show it. https://www.dropbox.com/s/qo6ja2eswodjick/buttons.mov?dl=0


(Robert Ziebol 🖖🏼) #16

Very strange. @gary555, try deleting everything from the server and do a Republish All Files once that is done and see if it still happens after. Never seen this reported by anyone else, and now it is happening on other machines, strange.


(Gary Davis) #17

Am I luxuriating in the feeling of vindication that my blue-button error is real and proliferates around the globe? Yes, I am. Oh, wait… Well, anyway, Zeebe, I did that. Deleted the files at GoDaddy and republished them all. The button still does the same thing for me. No change. Actually, I had changed out that button group at one point, replacing the one put there before the Stacks 3 updates with one after and that did not change the blue thing happening, either.

Has to be some clue in the specific things you have to do to make it happen. 1. Click on the button. 2. Go back to Home from the Lawyers or Dentists page using the browser back arrow. 3. Move your cursor near the button. That makes it turn blue (for me and the other Chosen Ones). Then, clicking anywhere else on the page turns it back to green. And if you go back to Home from the Lawyers or Dentists page using the Home link in the menu, then it never turns blue.

BTW, I tried this process with every other button in my site that links to anything and did not find it happening anywhere else.

Has anyone tried it with IE or Opera? I get no blue-button effect with Chrome.


(Peter Danckwerts) #18

Very odd. I still cannot replicate it on Safari 8.0.8 however hard I try.