What's going on with my Foundation button group?


(Gary Davis) #1

Don’t know if this is a Stacks 3 thing or a Foundation thing. Or a me thing. Anyway, on my home page here http://televisionadvertising.com I have a double button group with links to a couple of other pages. Something weird is going on with the button color.

I changed a picture on that page, after which my legacy (pre-Stacks 3) button group did not work right, so had to replace it with the new one. Should be just green all the time. Used a “Swatch 1” setting to get the color. (Took me a while to figure that out.) Now, looks fine (green) except, on the published page, after you use the button/link to go to the other page and you come back, the color of the button you just used has changed to blue. Like it has a “used link” color. But why it does that and where it got that color, I don’t know. And I can’t change it.

Ideas?


(Robert Ziebol 🖖🏼) #2

Could be a cache issue, works fine for me in Safari, see this movie:

https://www.dropbox.com/s/ei0kp8elnct8stk/button-group-works.mov?dl=0

Menu issue, what do you have the menu set to Static, Fixed or Sticky??


(Robert Ziebol 🖖🏼) #3

OK, the top bar issue is because you have a long title and there is no room for the menu to appear, you can see it has dropped below (you can even hover over the buttons), you need to set the width of the page bigger or make the title smaller for it to work.

Zeebe
I do support for Joe Workman, so please check out his stacks and his GREAT Foundation Theme


(Gary Davis) #4

I liked the cache idea and sure enough it worked fine on my iPad BUT I cleared my Safari cache and it still turned blue. So, I went to the back office and used my wife’s iMac, which has not pulled up my website in ages, if then, and the button went blue there, too. Made a movie for you. (Thanks for re-introducing me to Screenflow!)

Let me know if that does not work. Also, thanks for clearing up my menu issue on the “Denture Clinics” page. Turned out, the problem was that the Jack Stack the logo image and top bar are sitting in was set for too narrow a maximum – 1040 on other pages but 800 on that page. Not sure when that happened. It’s set for “sticky”. And I have the menu back on the “Denture” page.

Addendum: After re-publishing a few times, the last time I tried, button was ok. I think I have some publishing issues. I will edit, then publish. In the past, if I tried to re-publish right then, it would just tell me I had nothing more. Now, it will publish again and again, several times. Like it keeps missing stuff each time and finds it during the next sweep. This problem seemed to get better, the more I published, although I wasn’t editing it anymore.

Addendumdum: Hmm. Problem still there, after all. Not as often, though. I changed the source of the button color from Swatch 1 to primary Site Element color. Didn’t fix it, though. Well, pretty minor.